ProffieBoard 2.2 and Windows 11

Did you try Zadig 2.7?

WebUSB has to be on in Arduino → Tools → USB Type when the board is programmed for WebUSB to work. I assume whoever installed your saber did not do that.

OK, I just verified that the board is programmed with v5.6 right now (I did this using the version command from the Serial Monitor in Arduino). And I cannot say what they programmed the board with as far as options. I know they turned off the gesture controls, so I would not be completely surprised if they did not enable WebUSB either.

My only hope seems to be to get this to work somehow when the board goes into BOOTLOADER mode. And I cannot seem to get that to work right now. The moment the board is forcibly rebooted into DFU mode by the upload process in Arduino, it does not work and the upload fails.

Yes, I did try to use ZADIG 2.7… I made sure it was up to date… This is the error that I see in the log when it attempts to install the WebUSB driver for the STM32 BOOTLOADER device.

libwdi:debug [installer process] This version of Windows is refusing to trust the installed certificate.
libwdi:debug [process_message] Installer process completed
Driver Installation: FAILED (Operation not supported or not implemented)
1 device found.
libwdi:debug [wdi_create_list] Hardware ID: USB\VID_0483&PID_DF11&REV_2200
libwdi:debug [wdi_create_list] Compatible ID: USB\COMPAT_VID_0483&Class_FE&SubClass_01&Prot_02
libwdi:debug [wdi_create_list] Driverless USB device (12): USB\VID_0483&PID_DF11\207437735956
libwdi:debug [wdi_create_list] Device description: ‘STM32 BOOTLOADER’

I’m not sure who that would help, but I thought I would post it just to show what’s failing with ZADIG.

It may be possible to program the board using webdfu: GitHub - devanlai/webdfu: WebUSB Device Firmware Upgrade example
This would mean running “verify” in arduino, then finding the right file in the arduino work directory and uploading it through webdfu. You can also use webdfu to do backups of the program that is currently on your proffieboard, assuming it works of course.

I have a simplified version of webdfu here:
https://profezzorn.github.io/webdfu/dfu-util/

1 Like

Never mind, I just saw this:

“On Windows, that means that an appropriate WinUSB/libusb driver must first be installed. This can be done manually with programs such as Zadig or automatically (sometimes…) with WCID

I made progress and got the saber update to 5.9. I also enabled WebUSB now and I can see the SD card when the saber is plugged into my PC.

However, to do it, I had to manually update the driver to MSFT’s newest WebUSB driver.

First, I connected my saber and entered Arduino. Opened the Serial Monitor. Issued the RebootDFU command. Opened Device Manager for Windows and verified that STM32 BOOTLOADER was displayed there under “Other Devices”. Right clicked on that device and selected Update Driver.

And then, I followed Steps 1-7 at the following URL.

WinUSB (Winusb.sys) Installation - Windows drivers | Microsoft Docs

I am still troubleshooting my config. For instance, I am now seeing errors when I issue the effects command in the serial monitor. It shows something about unnumbered files in one of my fonts or folders… Not sure yet.

1 Like

I suggest starting a new thread, then cut-n-paste the errors you’re not sure about and then I (or someone else) can explain what’s going on.

2 Likes

Thank you, I will do that. Again, thank you for your help and assistance. It is so very much appreciated.

Is libusbK a thing?

It’s a thing, I don’t know if it’s the right thing.

If anyone needs me to do some screen grabs of what I did or wants to chat in real time about what I did, I am happy to do so. If it helps others get through this. There is obviously a WebUSB driver in Windows 11, it’s just a matter of how you get that driver associated with the device.

ZADIG was a great tool and did some “interesting” things to get around MSFT’s driver signature requirements. But, since the great printer driver fiasco of 2020/2021, it appears that MSFT has taken a harder stance on driver signatures and code signing in general.

Lest it not be obvious, I do work in IT. Otherwise, I would not have attempted to go through this to begin with.

1 Like

If you have the time, updating the wiki page might be helpful to people.
I suspect that you can do the same on windows 10 and avoid using zadig entirely.

3 Likes

I know I’m going to feel dumb but I’m stuck with Arduino under Tools>Ports, “Ports” is actually greyed out. The Proffie is showing as an unknown device in my “Printers and Devices” but I can’t actually find it in the device manager? Any suggestions?

Hi DropKAG,

Thanks for posting in the Crucible your issues. There’s a few assumptions I’m making and would like to clarify.

  1. Is this the first proffie core?

  2. Have you followed the Video on installing the proffieboard?
    Proffieboard, Zadig and Ports walkthrough - YouTube

The behaviour your experiencing sounds like the drivers are not installed.

I tried to install Windows 11 today, but because of all the secure boot and TPM stuff, I failed. I think my computer supports those things, but i turned them off a long time ago to make it easy to run linux, and turning it on again seems to be easier said than done…

I have the same problem. Not even sure I’m going to bother.

I’d like to have a windows 11 installation though to be able to help users with windows 11 problems.

1 Like

I’ve held back on upgrading to Windows 11 purely because of compatability concerns for some of my software that I use, now it turns out that this may not have been a bad decision.
Will be interesting to find out what is causing a lot of this and how we work around it.

Finally got Windows 11 installed.
Of course, now it’s bedtime, but I should be able to try some stuff tomorrow.

2 Likes

So I went spelunking in Windows 11 today.
After the upgrade from Windows 10 to Windows 11, Arduino worked just fine, because it remembered the driver I had installed previously.

So I uninstalled that.

Apparently it then found a driver from ST-Micro that I had installed at some point. Unfortunately, that driver did not work with arduino.

So I uninstalled that.

Then I tried the solution described by RORWessels earlier in this thread, which made it use the Microsoft WinUSB driver. That worked with arduino with no problems.

So I uninstalled that.

Then I tried Zadig 2.7, which also worked just fine.

Basically, I had no problems whatsoever with doing all this in Windows 11. I’m not sure if this is because I just installed an update from Microsoft, or if there is something else going on. Maybe my system isn’t configured for maximum security or something? To me this is sort of good news / bad news: On one hand it works just fine, on the other hand, I can’t replicate and help with the problems that others have experienced…

2 Likes