Proffie V3 button issue

This is a weird one, none of the buttons are shorted. When I turn on the kill switch, saber ignites immediately. Just for testing purposes I installed a third button to the BTN 3 pad. When I turn on the saber, hold button 3 down, the first and second buttons work normally and the saber operates normally. LEDs are fine, blade is fine. Just the weird button issue. Thoughts?

Check the voltage between each button pad and ground. It should be around 3.3 volts give or take. If it’s lower or floating around a bit, check those pads for stray strands, specks of solder or flux residue and try re-flowing the joint. If that doesn’t work, try unsoldering the switch wire and check the voltage again at the button pad. If the voltage with no wire attached is correct, then the problem is with the wiring somewhere, or the switch. I’ve had this a couple of times (one of them this week as it happens, though not with a V3 board). On one occasion, replacing the switch fixed it, but on other occasions I’ve found just scrupulously cleaning the top and the underside of the board with isopropyl alcohol around those pads and reflowing the joint fixed it.

Buttons one and two are stuck right at 3.26V. No wavering at all. Button 3, the one I hold down and everything works, wavers from 0.72 to 1.15V. I’m going to re wire all the buttons again later and also take out the switch to test that.

Stripped the whole thing, cleaned it with IPA, looked at it with a jewelers loop, found a bad mosfet, changed it out. Same problem. Wired only battery, speaker, and the two buttons. Blade ignites immediately upon applying power. It works perfectly when I bridge the BTN3 pad with ground which is weird. I dont need a third button so that might not be an issue, just wondering if that would hurt anything in the long run.

Need to see your config file.

chosenvictor_config.h (12.4 KB)

OH. Well you’re using dual prop, and you’re in blaster mode without a blade inserted (btn3 pad a.k.a. aux2Pin). Although you don’t have a blaster presets array.

Blaster mode doesn’t have an on/off state. It’s just on.

That did it. I feel stupid. Thanks for the help!