Proffie OS7.8 Intermittent not registering blaster bolt

I flash my Proffie saber using OS7.8 and noticing during pressing Aux button for blaster bolts multiple times, sometimes it’s intermittent not registering the blaster bolt. When I revert back to OS6.9 it does not seem to have this issue. Had replaced SD card, also add on #define KILL_OLD_PLAYERS in config but still not resolving it. I tried to attach 2 videos showing the difference using OS7.8 and OS6.9 using same soundfont but I was not allowed to attach them. FYI…this happens to all sound fonts. I had made a post in FB Proffieboard support group as well.

I recommend uploading the videos to Youtube or Google Photos, then sharing the link here.

However, I’m actually mostly interested in what it says in the serial monitor.
Is it actually missing the button presses, or is it just not finding a wav player to play the sound?

Also, we might need to see your config file, since this might be a config file thing.

Sorry forgot to mention I had also connect to serial monitor but I was unable to get any mis trigger while using serial monitor. All blaster blocks seem ok.

OS7.8 video: you can notice during multiple clicks some click is not registered.

OS6.9 video : all clicks ok.

Sixconfig.h (79.0 KB)

It seems like 6.9 and 7.8 should behave fairly similar here.
I checked the config file, and I don’t see anything wrong with it.
It’s really weird that it doesn’t seem to happen when USB is connected though, because that really shouldn’t matter.

Unfortunately I think I would need to see what happens in the serial monitor to figure this one out.

From the 2 video you can see that for OS7.8 some click does not register the blaster bolt . While the OS6.9 every click register the blaster bolt. I will try again on serial monitor and see if I can get any error. Thanks.

Blaster_Bolt_Serial_monitor.txt (10.4 KB)

I attached the messages from serial monitor as reference.

Just observing.
THe typical sequence is this:

EVENT: Aux-Pressed#1 ON millis=90953
EVENT: Aux-Pressed ON millis=90953
EVENT: Aux-Released#1 ON millis=91027
EVENT: Aux-Released ON millis=91027
EVENT: Aux-Shortclick#1 ON millis=91027
EVENT: Aux-Shortclick ON millis=91027
unit = 4 vol = 0.50, Playing 11-THEXAN/blst/blst01.wav
channels: 1 rate: 44100 bits: 16

and the anomally, possibly where you’re getting “duds” is where a second blst is triggered after only a Pressed event?

EVENT: Aux-Pressed#1 ON millis=92866
EVENT: Aux-Pressed ON millis=92866
EVENT: Aux-Released#1 ON millis=92961
EVENT: Aux-Released ON millis=92961
EVENT: Aux-Shortclick#1 ON millis=92961
EVENT: Aux-Shortclick ON millis=92961
unit = 4 vol = 0.50, Playing 11-THEXAN/blst/blst04.wav
channels: 1 rate: 44100 bits: 16
EVENT: Aux-Pressed#2 ON millis=93304
unit = 1 vol = 0.50, Playing 11-THEXAN/blst/blst05.wav
channels: 1 rate: 44100 bits: 16

but it says it’s playing a blst sound, in fact 2 of them, so I’m not sure how that translates to no sound.

He did the next click BEFORE the saved click cleared, the prop still triggers blast on EVENT_DOUBLE_CLICK so it shouldn’t be an issue as we can see blast still plays.

Yeah agreed. I don’t see anything indicating a failure to play.
I would usually say it’s just the button not registering, but if it’s one OS vs another…it’s weird.

I tried again reflash to OS6.9 and also Sabertrio preconfig that also uses 6.9 and I don’t see this issue even I press the Aux multiple times with fast speed. Flash to 7.8 and it does it again. Weird. I’m sure it’s not the button issue cause it works in all ways like tip drag, melt and preset selection and all other functions that uses the Aux button.

The other possibility here is that it’s some sort of race condition.
It’s possible that under some circumstances it says that it’s playing something, but then doesn’t actually do it. If such a thing happens, I would think it would be when it kills an old player.

Liu_Six: Do you have any idea what part of this serial output represents the time when the sound didn’t play?

Long shot, but could it be playing the same effect twice but so close together that they’re phase cancelling? Unlikely but thought it worth eliminating from the enquiry.

They’d only phase cancel to silence if played at the same time and for some reason one played 180 degrees opposite. That’s not possible to my knowledge.

1 Like

Also, the serial monitor shows the effects playing at different times.

1 Like

No. But I will try on serial monitor for few more times to see if I am able to catch the moment when it does not register blaster.

I tried the serial monitor again and capture the message. Still no error. But I notice when it happen it still register a blast and play the blast but no sound. I put an arrow at probable the mis trigger happen at the log attached.
Serial_Monitor_Blaster2.txt (10.8 KB)