Proffie board not responding

My board seems to be deceased all of a sudden. I went to upload a new config and my Mac died mid upload. Now the board won’t respond to a battery being connected, or the USB cable being plugged in. Not showing up in the ports section of Arduino either. I have tried entering boot loader and uploading anyway, but no success yet.
Ideas?

This is the error code i’m getting when trying to upload after entering boot loader

Arduino: 1.8.13 (Mac OS X), Board: "Proffieboard V2, Serial, SDCARD (SPI), 80 MHz, Smallest Code"

/Users/olliethelning/Library/Arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/arm-none-eabi-gcc-ar: Cannot find plugin 'liblto_plugin.so'
exit status 1
Error compiling for board Proffieboard V2.


This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Do the BOOT+RESET dance:

  1. Connect board to computer.
  2. hold BOOT
  3. Press and release RESET
  4. release BOOT
  5. Check that tbe board shows up on as STM32 BOOTLOADER on your computer. (USB connection issues · profezzorn/ProffieOS Wiki · GitHub)
  6. Press upload in Arduino. (Note, the port may not be available, but that doesn’t matter, you should still be able to upload.)

If pressing boot and reset is hard, this may be easier:

  1. Make sure board is disconnected from all batteries and USB power.
  2. Hold BOOT
  3. Connect USB cable.
  4. Go to step 5 above.

I’ve repeated this numerous times with no luck. I am receiving an error when hitting upload

The LTO error is a problem with compilation and is unrelated to any problems with your board.
Not sure I know what causes that error, but I guess you should try to re-install the arduino-proffieboard plugin.

1 Like

I’ve just tried to upload to another board in a different saber and get the same lot error.
This board was recognised in Arduino port, however the non-responsive board won’t even show in ports. I’m hoping the bootloader upload will fix that.
Will reinstall and report back.
Thanks Fredrik

Thanks @profezzorn this did the trick.
You wouldn’t believe how relieved I am!

I’ve fried my fair share of electronics. I know how it feels!

2 Likes

It’s not a nice feeling that’s for sure. Especially when it’s a commissioned build :expressionless:

1 Like