Proffie 2.2 Board Not Showing at all

Hi everyone, I have ran into an annoying issue. My proffie 2.2 board does not show up on my pc. I have watched many tutorials, reset my pc, unplug and plugged it back again, tried the BOOT + RESET buttons, and different cords and ports, and an entirely new pc. NOTHING is working. The board itself still works. I, for some odd reason, was able to put the factory fonts and blade styles back since i did make a copy. however, I am unable to upload any new bladestyles through arduino because the board doesnt show up. Any solutions? This is my last ditch effort because no other forums, videos or subreddits have any related solutions.

HI Phillip,

did the proffieboard ever connect to the pc, and your operating system I assume is Windows, correct?

the proper procedure of installing the proffieboard to the windows server is as follows.

this will outline the gotcha’s for windows, one of the gotcha’s is that when you use zadig you install the wrong driver, as stated by Proffezorn you need to click on boot and reset until you see the correct driver to install.

I would go through the whole video and watch it till the end and then watch it again and follow it along and pausing when required.

Have you tried this?

1 Like