Power button on Verndari not working

Hi everyone,
Ordered a Verndari core and it was working perfectly when I got it.
I have tried to update the config with some additional fonts but now the power button is not working. It comes on with a twist but I can’t get clash to work or live to the next font etc. The config complied and uploads to the core with no issues but clearly I’m missing something.
Would anyone be able to see what I’m missing at all please?
Any and all help appreciated.
I have attached the config as well.
Thanks everyone.

I also tried this version based on another topic but this didn’t seem to do it either.

Did you load the original config back on to see it works?
There’s only 2 things in the config file that would change regarding buttons.
The NUM_BUTTONS entry, and the CONFIG_BUTTONS section.
If those are the same as the original, then things should work fine. If if doesn’t work, then you should look at the switch button itself, like test it with a multimeter to see if it’s working, check the wiring to the board etc…

Thanks for the reply @NoSloppy I did try and reload the original config and unfortunately had the same outcome which threw me a little as I expected it to go back to as it was beforehand. I’ll take a look to make sure that the NUM_BUTTONS and CONFIG_BUTTONS are the same as the original, just in case I’ve amended it in some way. I’ll come back asap :+1:t2:

Just to make sure, do you have a Proffieboard V2 or V3? The fact that you’re having issues with clash makes that a suspect…

It’s a V3 Brian

So what does the original config file look like?

Hi @profezzorn - here’s the original config.

Clash does seem to work but with effort, so may need to turn down the sensitivity, but it’s the power button not working for blasts and changing fonts that is flummoxing me.

So, the first config that you posted, has NUM_BLADES set to 2, but only one blade in the blades array. Did that even compile? Are you sure you actually uploaded this config file to your saber?

The first config also uses a different prop file, which would mean that things like power on/off might work differently.

I have made a number of different configs based on the original one and another thread here and they are all compiling, but none of the variations I try mean the power button then works. Am definitely new to this so not 100% how to correct it. Would you recommend I use @Fett263 's config builder and start from scratch? I’m using OS7.14 and Arduino 1.8.16 if that makes any difference at all?

I’ve also reached out to the supplier just to double check the config on the sd card was correct.

Does the power button work if you use the original configuration file?

Afraid not, I had hoped it would just go back to how it was when it worked initially and now
that’s what makes me think the config I was working from is not correct.

Well, either it means that none of these configurations are correct.
For instance, the installer could have wired the power button to AUX instead by mistake and just fixed it by changing the configuration.

The other alternative is that the button wire has come loose or broken while you’ve been doing the programming, causing the button to not work.

Thanks @profezzorn I’ve contacted the supplier for some assistance. I’ll feed back when I can. Thanks to everyone for the replies as always, much appreciated.

Update on this. All solved. Turns out the config I had was like this:
Button PowerButton(BUTTON_POWER, powerButtonPin, “pow”);

But needed to be this:
Button AuxButton(BUTTON_AUX, powerButtonPin, “pow”),
Button PowerButton(BUTTON_POWER, aux Pin, “aux”);

Works a treat now :smiley:

1 Like