Potentially fried my Proffieboard


It seems I have somehow fried my proffie. Maybe someone has an idea how to debug this and maybe potentially fix it. I have no idea how this happend but here is what I did.

I tried to put on the oled cover of my mb-sabers metal master lightsaber. After that the proffie did not turn on anymore. Before everything worked fine. There was no obvious wire lose or sticking out anywhere and I insulated everything well. So I’m not sure what exactly happend.

I tried to debug this by plugging in the board to my pc. However, the proffie doesn not show up. Instead I get the warning (Unknown USB Device (Device Descriptor Request Failed). When plugging the board in to the usb port some components get warm quiet fast. First I thought the capacitor next to the boot button was fried becaus there seemd to be a major heat source but the component seems fine. Now I think it’s either the 3.3v regulator that is broken or the STM chip itself. Because measuring out the board it seems that the 3.3v line has a short to ground somewhere. But I have no idea where. I took the saber apart and somewhat cleaned the board but the issue remains.

Next I wanted to try to reflow everything using a hot air gun. But first I wanted to ask whether I should/could try our other steps. Or maybe this is pointless and I should buy a new board.


Have you de-soldered all the wires from your board yet?
Seems to me that the most likely cause here is a short in or near the OLED display (which has GND and 3.3v wires.)

Yes I have removed the soundboard from the saber and de-soldered all the wires. Currently the proffie is in it’s delivery state.

Any other suggestions. I wrote the post after i de-soldered all wires. Probably the board or at least one of the two mentioned components is really toast.

Do you have 3.3v between the 3.3v pad and GND when the board is plugged into USB?

No, I measure 0.0v between 3.3v pad and GND with the board plugged in.

Without the 3.3 volts, the board will not work.
The question is why. It may be fixable.
Options include:

  1. USB power is not making it to the 3.3v regulator. This could be a problem with D61, or with the charging circuit. if this is a V3 board, then it should try to charge the battery when USB is connected, do you see 4.2 volts between BATT+ and GND?
  2. 3.3v regulator is not working (can be fixed by replacing it)
  3. There is a short between 3.3v and GND somewhere. This could be a small wire, or a blob of solder. If there is a short, the “beep mode” on your multimeter will measure GND and 3.3v as connected.
  4. Some chip (like the cpu) has melted on the inside and is creating a short. If this is happening, the board will get warm or hot when plugged in. Replacing the CPU is hard, so if this is the problem, then you probably need a new board.