Port busy" error

Every time I try to upload my config I get “Error opening serial port ‘COM4’. (Port busy)” I have uploaded the config multiple times before. Someone has suggested it might be my computer. If so I have a less than a month old Lenovo Legion 5.

c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/../lib/gcc/arm-none-eabi/9.3.1/../../../../arm-none-eabi/bin/ld.exe:C:\Users\Jacob\Documents\ArduinoData\packages\proffieboard\hardware\stm32l4\3.6.0\variants\STM32L433CC-ProffieboardV2/linker_scripts/STM32L433CC_FLASH.ld:224: warning: memory region `SRAM2' not declared
Sketch uses 239288 bytes (91%) of program storage space. Maximum is 262144 bytes.
processing.app.debug.RunnerException
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:152)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
	at processing.app.SketchController.upload(SketchController.java:732)
	at processing.app.SketchController.exportApplet(SketchController.java:703)
	at processing.app.Editor$UploadHandler.run(Editor.java:2061)
	at java.lang.Thread.run(Thread.java:748)
Caused by: processing.app.SerialException: Error touching serial port 'COM4'.
	at processing.app.Serial.touchForCDCReset(Serial.java:107)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:136)
	... 5 more
Caused by: jssc.SerialPortException: Port name - COM4; Method name - openPort(); Exception type - Port busy.
	at jssc.SerialPort.openPort(SerialPort.java:164)
	at processing.app.Serial.touchForCDCReset(Serial.java:101)
	... 6 more
Error opening serial port 'COM4'. (Port busy)

That’s a new one… just to give you something to try until smarter minds weigh in, did you try swapping USB ports on the computer? Also, you’re going straight into the computer right? No hubs? Lastly, did you try restarting the computer?

Very annoying hahahaa, I have 4 separate ports that I have used, all the same outcome and I’ve used hubs, no hubs, different cables. The works! Restarted my computer, re installed arduino

Once again, put it through zadig and it works the first upload then errors if I try again

I, literally a half hour ago, solved a hellacious issue that had been bugging me for almost a month. And by solved, I mean it randomly resolved itself out of the blue, with no indication of what I did to solve it. So trust me, I both feel your pain and am eager to see your overcome it.

Try forcing bootloader mode (2 buttons push). Ignore not being able to select a port after that and just upload anyway. Any luck?

If the port is busy, then some other program is talking to it.
Do you have other devices on your system that has COM ports?

I recommend using a hub, that protects your computer from any shorts or other crap that could happen in your saber.

You don’t need to run zadig. You can just do BOOT+RESET and then hit upload.
(The reason running zadig works is because after you do that, the board is in bootloader mode, not because you ran zadig.)

No kidding! Thought I heard somewhere that going straight in was ideal, but that makes sense.

That’s just for troubleshooting.
If you have problems with a hub, try without it.
If that doesn’t turn out to be the problem, then use a hub.

Gotcha. Thx for the wisdom as always!

It’s allowing me to upload after I put it through zadig and use a different port each time, I just did it and got the error directly after

Arduino: 1.8.19 (Windows Store 1.8.57.0) (Windows 10), Board: “Proffieboard V2, Serial + WebUSB, SDCARD (SPI), 80 MHz, Smallest Code”
c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe:C:\Users\Jacob\Documents\ArduinoData\packages\proffieboard\hardware\stm32l4\3.6.0\variants\STM32L433CC-ProffieboardV2/linker_scripts/STM32L433CC_FLASH.ld:224: warning: memory region SRAM2’ not declared
c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: warning: changing start of section .bss by 24 bytes
c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: warning: changing start of section .bss by 24 bytes
c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: warning: changing start of section .bss by 24 bytes
c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: warning: changing start of section .bss by 24 bytes
c:/users/jacob/documents/arduinodata/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: warning: changing start of section .bss by 24 bytes
Sketch uses 180944 bytes (69%) of program storage space. Maximum is 262144 bytes.
Cannot open DFU device 0483:df11
dfu-util 0.9
`
Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util / Tickets

Opening DFU capable USB device…
ID 0483:df11
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 2048
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08000000, size = 180952
Download [=========================] 100% 180952 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state Cannot open DFU device 0483:df11 processing.app.SerialException: Error opening serial port ‘COM4’.
at processing.app.Serial.(Serial.java:152)
at processing.app.Serial.(Serial.java:82)
at processing.app.SerialMonitor$2.(SerialMonitor.java:132)
at processing.app.SerialMonitor.open(SerialMonitor.java:132)
at processing.app.AbstractMonitor.resume(AbstractMonitor.java:132)
at processing.app.Editor.resumeOrCloseSerialMonitor(Editor.java:2126)
at processing.app.Editor.access$1300(Editor.java:116)
at processing.app.Editor$UploadHandler.run(Editor.java:2095)
at java.lang.Thread.run(Thread.java:748)Caused by: jssc.SerialPortException: Port name - COM4; Method name - openPort(); Exception type - Port not found.
at jssc.SerialPort.openPort(SerialPort.java:167)
at processing.app.Serial.(Serial.java:141)
… 8 moreError opening serial port ‘COM4’.

No other devices, just the COM ports proffie boards show up in

Still, there must be some program on your computer that is using the port.
I don’t suppose you could try a different computer?

Unfortunately not :frowning: I got this laptop recently because my pc broke. I will check to see if there is anything else interfering

Okay, I just ran all of the updates on my pc and it’s working consistently now… A reminder to save yourself a day and check for windows updates!? <3

1 Like

After a couple of successful uploads on multiple board I’m getting the same errors again, I thought it might be anti virus or firewall intercepting it while uploading but I turned that all off and I’m still getting the error. I can upload after I run it through zadig again!

I did a quick search on the arduino boards and found two programs that could be interfering:

  • Cura (slicer program for 3d printer)
  • PLX-DAQ (excel plugin for acquiring data over a serial port)

Do you have either of those installed, or some other program that might be communicating with a serial port?

Sorry for the late reply, I have Cura installed

I’ve just closed it down and restarted arduino, worked first time. I’m going to check some other boards I have. You are a computer wizard!

I disables the USB Printing in Cura settings and uploads are working no problem! woooooooooo