Play Force Quotes in Sequence


For Fett263 config helper, wanted to see if/how I can set my saber so that the force/quote sounds that play during force effects can cycle through the full sequence before repeating.

I know it’s not technically repeating, in the sense that it won’t play the same force/quote back to back. To clarify, if I have sound files force1, force2 etc. up to force8, can I set it so that each time I trigger the force effect, it will play 1-8 in order then start again at 1?

I have ‘Randomize Quote Player’ unchecked, but I’m not sure that matters, since these are formatted as force sounds. Also have ‘No Repeat Random’ selected (which is successfully preventing back-to-back repeats).

Quotes play sequentially by default in my prop, force effects do not. Use Quote Player in my prop if you want sequential, it doesn’t matter what the sounds actually are, they just need to be named quoteNN.wav and they play sequentially when you have Quote Player running, if you name the sounds forceNN.wav they play with Force Effect and will be random.

If you “Randomize Quote Player” then both quote and force will be randomly played.

If you want to have the Quote Player start on by default use the associated define.

Refer to controls for Force/Quote Player in my prop for more information:

You can also use Special Abilities in my prop (via OS7 library) to play quotes, just set for “Next Quote” and it will play the next sequential quote with each control (if you prefer to have the Quotes on a separate control from the force effect). You’d probably want to disable the Quote Player in that case (refer to defines).

1 Like

Thanks - Right now force and quote sounds are all labeled force(#) to be incorporated into the force effect. I’m not familiar with what happens when they’re labeled quote(#), I’m guessing it just plays the sound when you press the necessary controls, without any particular visual component.

If that’s the case, I’d actually prefer to keep the quotes/force sounds all within the force effect (gives a spiritual otherworldly vibe to the character quotes when hearing them speak =] ). I guess that means I have to accept that they won’t play in straight sequence

Or, you could just make them all quote.wavs then just change the blade styles to use EFFECT_QUOTE instead of EFFECT_FORCE.
You could also modify things in the prop a bit to have force and quote always separate… just depends on how far down the rabbit hole you want to go :slight_smile:

Quotes were separated out and set sequentially to be their own thing in OS6. As NoSloppy noted you can change the behavior if you want to modify the code but the force.wav default behavior is always random and quote.wav is sequential already if you really want the sounds sequentially just changing the filenames would give you what you want much easier.

Thanks :slightly_smiling_face: - I tried changing the sound labels and the effect code, but then when I tried the long click nothing happened (one-button). Might read up a little more on it to see if I can figure it out, or just be less nitpicky :grin:

Make sure the quote.wav files are not in a folder named ‘force’, the OS won’t see them. They will need to be in the root or a folder named ‘quote’.

Review the controls for Quote Player.