Old font set up on new 3.9 board, "font directory not found error"

I just wired up my 1st Proffie 3.9 in a Waspwaist TFU1 , updated my OS to 7, updated my config to v3 , and made sure it compiled correctly ( no errors on the 1st attempt) I am using a font package I made for an older build with Proffie 2.2. When I plug in the usb cord, I keep getting the font directory not found message. Is there a need to change, or add anything to my sd card beyond my current font set and txt. copy of my OS? (I have reformatted two 32 gb Sandisk sd cards with the same results

When you boot the saber do you get the talkie voice playing at the same time as a boot.wav? Or do you get the double ‘font dir not found, sd card not found’ and silence?

Are you using the saber_fett263_buttons.h prop file?
You’ll need to use a “common” font folder as well and have it in your font path in the preset.
see the section " Set Up for Voice Prompts (Required)" on this page:

1 Like

Thank you for the heads up, I just downloaded it and added it to my sd card. I will add it to the OS per instructions, …Is there an example somewhere to see the script on an OS? I’m a bit lost on what gets added

Not sure what you mean. If you’re referring to how to add it to the preset, it shows the syntax in that section. It’s like this.

{ "font;common", "font/tracks/track.wav",

To understand how font search paths work and why adding the common folder to the path does what it does, you can check out this page:

Ok it’s beginning to make more sense now. Does the name matter at the end of te blade styles? or does that get the font name? here is my attempt at a basic blade style
{ "“SmthJedi;common”, “mars/tracks/track.wav,;common”, "SmthJedi/tracks/track.wav,
StylePtr<InOutSparkTip<EASYBLADE(BLUE, WHITE), 300, 800> >(),
StylePtr<InOutSparkTip<EASYBLADE(BLUE, WHITE), 300, 800> >(),
StylePtr<InOutSparkTip<EASYBLADE(BLUE, WHITE), 300, 800> >(), “blue”},

The name is for your reference. It is what gets displayed on the ProffieOS Workbench web page, the serial monitor, and on an OLED screen if no images for font are used.
Also, you have quotation mark issues above. Make sure you are editing in plain text. Also, you have multiple quotation marks where there should just be one.

Lastly, unless you plan on putting tracks in your common folder as well, you don’t need common in the track path. You also have an extra track argument in there. Format it just like the example…

Thank you again for your help, I have added the common folder to my sd card, and changed my OS per the addition of the common folder. The OS compiles, though I keep getting the sd card not found prompt when I plug in the usb cord. here is my config. #ifdef CONFIG_TOP#include "proffieboard_v3_config.h"#define NUM_BLADES 4#d - Pastebin.com

Sounds like you have Mass Storage turned on in the options under Arduino menu Tools>USB Type.
That’s going to make the SD card mount to the computer and act as a USB drive when USB is plugged in, and therefore not be available for the Proffieboard to use normally until you “eject” the SD card from the computer.

Ok , I have tried setting it to Serial and am getting the same results. I also wired u just a speaker to another board, to be sure it wasn’t the hardware. Same response of font directory not found. I know i’m getting close,

“Font directory not found” or “SD card not found” ?
Could you take a directory listing of your SD card and post here?
Otherwise, on your own, make certain the font name in the preset is identical to the font folder name, and that you don’t have subfolders in the font for different boards.
For example, a font purchased from Kyberphonic fonts would come like

|  |Proffie
|  |  blst
|  |  |  blst01.wav
|  |  |  blst02.wav
|  |  |  etc...
|  |CFX
|  |  blaster1.wav
|  |  blaster2.wav
|  |  etc...

It should just be the sound files in the folder, like:

|  |blst
|  |  blst01.wav
|  |  blst02.wav
|  |boot.wav
|  |etc...

Did you upload after changing this setting?

yes I did double check my font files (they are a package I built from a few different TFU1 font packages I have saved over the years (Lord Blakos mostly and proplicator fonts) I installed the package on a TFU1 a cple months with OS 5.9 on a proffie 2.2, and they worked great. The only thing I have added is the root common file

yes, I have tried serial then per the manual , serial +USB+Mass storage, with the same results

The confirmations needed here are:

  1. that you UPLOADED to the board without Mass Storage selected. (Serial only).
  2. which error specifically you are gettting, either “Font directory not found”, “SD Card not found”, or both.

Also, posting a directory listing of your SD card root level would be helpful.

Good morning NoSoppy, I have attempted to upload the board in both settings with serial only and with serial mass storage USB. with either attempt the OS wouldnt load onto the board. I am only getting the “font directory not found” . For the sd card root level, tbh I don’t know how to post that

How do you mean? What error message did you get?

with Arduino, I get the 1-10 countdown without it uploading. If i use the proffieboard site for upload it stalls afer initialization. I checked the config and it compiles correctly in Arduino

Under Tools > Port > select the COM with your board

1 Like