New SD Card but no backup

I purchased the DamienSabers Proffe 2.2 Black Hilt Saber a couple weeks ago and just now got around to pulling the sd card. come to find out the card was cracked and now I had to go get a new one. I never got a chance to save the orginal files from the card so now I have no backup or image. Does anyone have the backup files from the LGT/Damien saber they might have purchased if you all have one? Its the basic saber. Here is the link to it from aliexpress - Lgt Lightsaber-rgb Xenopixel Proffie Metal Hilt Heavy Dueling Light Saber With 12 Sound Fonts Sensitive Smooth Swing - Luminous Toys - AliExpress

Not looking for any paid fonts, Just the original backup file someone might have saved from their LGT/DamienSaber


I assume you also reached out to the seller to ask them for a copy of the files?

I have yes

Update and proper response

Just bought a new sd card and have xfer’d my backup proffie files to it and put it back into the saber but it says dir not found, sd card not found. I am using a Mac and I removed the battery then card and formatted the card on the Mac to FAT32 using the sd formatting app. Placed the card and battery back into saber and tried again and still no joy. I don’t think there is anything wrong with the saber cause it worked before switching the card (had to replace card cause it was cracked and finally was unreadable). Is there a better app on the Mac to format the card properly? Or is there anything I need to do with the files?

I dont know what i am doing wrong, i formatted the SD card and added my files, no files have been changed. I place the sd card in the saber, put the battery in. Something Dir Not found x2, sd not found

What size SD did you get?

Try using the SD card association formatter.
I think the mac formatter might create a GPT partition table rather than an MBR partition table.
Proffieboards do not support GPT. (yet)

If you talking about this one. I just used it - I moved over my backup file and placed in the saber and added the battery. It still says font dir not found, sd card not found.

I am such a novice at this trying to learn it, I should have never bought it

I have no idea whats wrong. I figured it would simply be formatting the sd card. moving over the unmodified orginal back up to card and put it back into the saber

So, I’m not sure what these last two pictures are supposed to show.
Please don’t post screenshots unless you need to. My server has limited amounts of space.

So, I’m not sure what’s going on here, but two things come to mind:

  1. It could be the SD card. Someone else had bought some SD cards that just wouldn’t work with proffieOS recently, and we’re still not sure why.
  2. There could be something wrong the SD card reader on the board. If the SD card got broken, maybe the SD card reader got damaged too?

That’s exactly correct.

Don’t feel like you jumped in over your head. You’re doing the right things, you’re just up against something odd that isn’t your fault so keep at it. Personally, I would try like three or four different cards. However, that’s because I have a ton of them laying around.

Thats what I thought. I have been working on this for 15 hours now. I am so confused at this point and had so many tutorials I have watched. everyone is telling me that I need to use Arduino to flash the proffieboard and I’m on a mac. I’m just tired at this point and defeated. I dont know what I am doing wrong. The mac shows the Proffieboard is connected when I connect it through the micro USB on the board. It even will allow me to Boot into STM32 Bootloader but when i try to upload through the Arduino app it gives me a no such file found. I have changed the #define CONFIG_FILE “sd config/LGT1Button32.h”. still no joy. I dont understand. I bought the Sandisk ultra PLUS 32gb A1 U10 card cause I have heard it works

I dont know I am giving up at this point. I wasted close to $300 at this point and reading and listneing to video are really bad for me cause I’m dyslexic. I need to be talked through something and then I get it. But its to the point where I am defeated. I cant get LGT to message me back on aliexpress now so Idk

Just for future reference, the built-in “Disk Utility” application on macOS can do both MBR and GPT partition maps. (It’s objectively better than Windows’ Disk Management too… but that’s neither here nor there)

FYI, the config file needs to be copied into your ProffieOS/config folder on the computer. It’s only on the SD card as backup storage. The board doesn’t read the file from there.
Your line in Arduino should be #define CONFIG_FILE "config/LGT1Button32.h" because it’s going to look for it there, in the ProffieOS/config folder.
You can totally flash the board with no SD card installed. The SD only holds your sound fonts.
Using MacOS vs. Windows makes no difference at all.
You actually have it easier because there’s no driver installation required.