New Sabertrio USB connectivity issues on PC

Hi all, certified newbie here.

I received my new Neo Proffie Sologaard from Sabetrio earlier this week and after playing around with the stock fonts, I went to add my own per the steps in their guide. Everything seemed to go OK up to & through the Arduino recompilation/uploading process, but then I ran to some issues:

After following the guide to add/edit sound fonts on my saber, re-inserting the SD card, and enabling the kill switch, no sound came from the speaker as it should. I re-connected the board to my PC (again, no sound when there was one before) and Windows only sort of recognized it (no new drive popped up in File Explorer) for a couple seconds before disconnecting and declaring there to be an issue with the device (Code 43).

On its own, the SD card reads fine and can be edited, but nothing is recognized while it is mounted in the chassis. If I power on the board without the SD card inserted, I hear the speaker say “No font folder found (x2). No SD card found,” which makes sense, but I believe that this at least indicates that the board was not fried somehow.

I have tried re-installing the drivers via Zadig, and doing the Boot & Reset button procedure multiple times while the USB cable is connected, but the problem persists.

I 'm reaching out to S3 support concurrent to making this post in the hope someone here can provide any advice while I wait to hear back from them over the weekend.

Edit your title to reflect it’s via PC. I’d love to chime in but can only offer support via Mac.

Updated. Thanks for the heads-up.

To me, it sounds like the board if freezing while trying to read the SD card.
This can happen if the SD card has been corrupted somehow.
If the offending file can be found, deleting/replacing it can fix the problem. If not, it’s usually best to just format the sd card and put all the files back.

Of course, it could be something else entirely…

I have tried reformatting the card and replacing the backup of all the stock files, but connectivity issues prevent me from re-comliling/uploading to the board

What issues though? You said if you remove the SD card the board works as expected. Just upload. You don’t need the SD card in to do that.

Did you try turning it on though? Or changing to next / previous presets?

Are you sure you actually have a boot.wav sound in the font path indicated in the first preset?
If not, you’re not going to hear anything on boot.

What does Serial Monitor say?

I seemed to have solved it. I swapped in a new 32GB SD card and copied over the backup of the load-out I put together, and now everything is working. Even the stock card now works with it as well, so I’m at a loss here of what the problem was, but at least I can breathe a huge sigh of relief.

1 Like

Hey ConstantTilt. We’re glad to hear that you were able to resolve the issue. Based on the description, it does sound that it was related to a read error on the soundboard.

That said, in the event you do encounter any further issues in the future, do drop us a message and we’ll be more than happy to assist! :slight_smile:

1 Like