New Proffie 3.9 Board Not working properly

I’ve just received a Proffie 3.9 alongside my saber order, and was working on getting things together and configured. The problem I’m having is rather complicated so I’ll give a brief explanation followed by the steps I have followed in testing.

Upon finishing the wiring of all the components and double checking everything, I attempted to toggle on the killswitch and power the board for the first time and didn’t get any sound or light. The only thing that signified anything was that the bluetooth LED was blinking. I flipped the killswitch off and checked all my connections and they looked good. Flipped it back on and got sound/light etc, but any time I turned it on after this, again there would be nothing but the BT LED.

I thought maybe there was a misconfiguration on the board, so I worked with some people on the discord to create and push up a new configuration to my proffie, but ended up at the same results with just the BT led being the only consistent thing. However, after a lot of trial and error, I have found a consistent, if inconvenient way to get the saber in the correct state. I’ve also used ryryog25’s proffie config tool to push a new configuration, and do bootloader recovery.

When initially powered on via USB/Battery:

  • BT LED comes on, nothing else, when connected via USB there is no proffieboard or bootloader in my devices

When holding BOOT and pressing RESET

  • Bootloader mode starts as expected and appears in my devices

When holding RESET and pressing BOOT

  • Over USB, this boots the saber into the appropriate mode. I get sound, light, OLED, everything. However, over battery, this does nothing.

I am unable to get the saber to turn on correctly over battery at all. The only thing that I can do is connect the battery, connect USB, and then do the RESET and BOOT method to get it working. At which point I can disconnect the saber from USB and battery will keep it running correctly no problem until I turn it off again, at which point it goes back to the standard BT LED on and nothing else. Also, to mention, in order to get the saber working, I have to put it in bootloader mode first, then reset, then reset and boot.

I’m at a loss for what could be causing this. Any help would be very appreciated.

When only the status led is working, is it pulsing, or is it static?
Does the serial monitor say anything helpful? (Like maybe “battery low” ?)

This is the same as just pressing reset.
Not only does the pressing BOOT while holding reset do nothing, it’s actually impossible for it to something, because the CPU is frozen while reset is held.

the BT LED is pulsing, and there’s also a green led on the proffie that is a static green.
The serial monitor doesn’t say anything as there’s no detected board. Once I have it boot up properly, it shows up fine, but there’s nothing in the monitor.

I don’t know how to explain what is happening then about Reset and Boot, I can’t get it to start any other way. I’ve tried just hitting reset several times just now, as well as trying boot individually. The only thing that turns it on is Reset + Boot, and only over USB.

After booting this way, does it keep working if you unplug USB?

It does, yeah. Once it’s booted like this, I can unplug and everything works fine on battery power until it’s turned off again. Then it boots up how it usually does with just the BT light blinking and nothing else

That really sounds like the infamous D61 problem, although the BOOT button requirement is new.

This let’s me use my new fancy part map:

Is there anything that I did to cause that potentially? Or just unlucky?

Also, from the sound of it, the D61 issue usually means the board boots up normally when attached to USB right? It might be a secondary issue that requires me to do the reset + boot?

It’s not clear what causes the D61 problem.
Could be some sort of short.
Could be static electricity.
Could be heat.
Could be bad components.

Since we don’t know what’s causing it, it’s hard to know if it’s something you did.

Correct, there may be a secondary issue at play here, it’s difficult to know until the first issue is fixed.
(If you have warrenty on the board, I suggest you use it.)