My Proffiebord won't connect to my Mac

There is no “Zadig” software for the Mac.
I tried several times to plug in my proffieboard and press “resset” while pressing “boot”: nothing happens.
I am really discouraged. Please help me

There is also no need for Zadig on Mac.
What are you trying to do?
What directions are you following?
How about following the directions here:
https://fredrik.hubbe.net/lightsaber/proffieos.html

As long as you have the board selected in the Ports menu, it should just work plug-n-play.

…additionally, if you’ve pressed and held BOOT then pressed and released RESET then released BOOT the board may still not show. Simply push the upload anyhow. It may take a few tries but this will result in the confirmation sound the board successfully took the upload.

Hello,

Thank you for your good advice… but none of it has worked so far.

I would like to point out that my ProffieBoard (2.2) is practically new and working. Indeed, I could connect it to my computer at the beginning, and I had time to program it once with Arduino.

Now, the ProffieBoard is totally invisible when I connect it to my computer. I can’t see it. I can’t see “STM32 BOOTLOADER.” I can’t even see the SD Card on any port, either with Arduino or using the OS (Apple Menu → About this Mac → System Report → USB) (or, on my PC: Start Menu → Control Panel → Devices and Printers).

So, my lightsaber works, but I can’t update it.

Here are my steps so far in more detail:

  1. I have tried many times to press “boot” then “reset,” then release “boot” then “reset.”

  2. I have also tried unplugging my Proffieboard completely, pressing “boot” and then plugging the Proffieboard back into the computer.

  3. I reinstalled several times the Arduino software and the Proffieboard plugin.

  4. I tried several previous versions of the Arduino software.

  5. I tried three USB data wires and all available USB ports.

  6. I tried another Proffiboard 2.2, which is new (never used)…

  7. I have changed my SD Card several times (it works, because I can plug it (separately) on my computer and I have checked it with a disk utility).

  8. I tried all the above on my Mac, but also on a PC (trying to find the right driver with Zadig).

  9. On my Mac, I temporarily disabled the firewall and “Bitedefender Shield.”

  10. I checked several times that my Mac was working properly with the routine algorithms of the “CleanMyMac” software.

  11. In desperation, I even completely reinstalled MacOS 12.6, then started all over again…

None of this worked. A real curse!

I can’t believe that everything is defective at the same time: my two new ProffieBoards, my three USB data wires, my Mac, my PC!

What to do now???

The Crucible community, you are my only hope!

So, if it doesn’t show up when you do BOOT+RESET, then there are really very few possibilities:

  1. The board is broken.
  2. The USB connection is not working.
  3. The computer is broken.
  4. You didn’t end up pressing BOOT+RESET correctly. (Which happens a lot, the buttons are small.)

Since you’ve tried multiples of everything, it seems like it can’t really be any of these, but it sort of has to be…

Just based on probability, I would start with trying more cables. Micro-usb cables are notoriously crappy, and it can be very difficult to tell a charge-only cable from a data cable. I remember one Proffieboard user who tried four different cables, and of course nothing worked, but the fifth one did! Obviously that’s unusual, but I have also thrown away dozens of non-working micro-usb cables over the years…

I hope you meant “hold boot while plugging the proffieboard back into the computer”.
If you just press and release boot, then plug it in, nothing happens.

None of these will do anything if you can’t see the board in the System Report / Devices and Printers after pressing BOOT+RESET.

Different things.
First, the SD Card doesn’t show up in Arduino at all.
It will only show up via USB to the computer as a hard drive if you’ve uploaded to the board with the Arduino menu Tools>USB Type set to an option that includes Mass Storage.
Third, what would show up in Window’s Devices and Printers would be the board itself.

It’s press and hold “boot” then press and release “reset,” then release “boot” .

Again, it’s HOLDING boot while applying power, then releasing that starts the board in bootloader mode.

This would likely show up straight in Arduino under Tools>Port as soon as you plug it in, unless you’ve messed with it and had a failed upload.

The board can power up and be programmed regardless of the SD card in.
Also, you should use this utility for formatting it instead of built-in MacOS Disk Utility:
SD Formatter

This is garbage software that should be considered malware and uninstalled completely.

Try the bootloader steps again, this time be sure to do it correctly and report back.
The “new” Proffieboard should just work, so check again.

Lastly, if BOTH boards happen to have a bad U40 chip (Such as some that were sold this year), then neither will work after all proper attempts have been made.

Where are the boards from?

Thank you for unpacking my problem. Thank you also for the advice. I’m looking at everything very carefully. I have already ordered two micro usb connectors, the best I could find. There is a good chance that this will solve my problem. To be continued…