I need help.. I attached a video


First of all, hello! I’m a Korean. I’m not good at English… I recently purchased 89saber proffie v2.2. If you keep pressing the auxiliary button, a strange sound will be output as shown in the video. why? ㅠㅠㅠㅠㅠㅠㅠhelp me… And I can‘t enter the volume control mode. Even if I wait for 1 second on the auxiliary button, there is no response even if I press the main button for 1-2 seconds. Even if I press the main button and give an impact, there is no reaction. Please tell me how to solve it. This is my first time using it.

“Font directory not found”, this means your preset is looking for a folder on your SD card that is missing. Compare the font name in your config to the folders in your SD and make sure they are same spelling and case.

1 Like

Thanks for the reply. First of all, I haven’t touched the file. Should I get the original file from the seller? Also, is the inability to access sound control a file problem?

Yes, if the installer didn’t provide a copy of the config then they need to provide. Not being able to access the SD card would be problematic, I would ask them how they expect you to access SD and if they don’t have a sufficient answer you may want to return the saber and work with someone who understands how Proffieboard works and is used better. You need easy access to the SD card because they can become corrupt or have issues.

I had this issue on my first built, it would turn on and even worked but every time I change fonts or power up it would give me that error, I found out that I had not installed the common file in the sd card. After that it worked right away.

I have the same hilt. You should be able to pull the chassis from the handle. I suspect the speaker compartment is stuck on the spacer that locks against the pommel to keep the chassis from moving around while using it. The pommel should also unscrew. That will make it easier to work with.

The font directories are case sensitive… i noticed some discrepancies in the default configuration file from 89sabers with mismatched cases… eg luke vs Luke.

Hopefully Google translate did its job…
나도 같은 칼자루를 가지고 있습니다. 핸들에서 섀시를 당길 수 있어야 합니다. 사용하는 동안 섀시가 움직이지 않도록 하기 위해 포멜에 고정되는 스페이서에 스피커 구획이 붙어 있는 것 같습니다. 포멜도 풀어야합니다. 그러면 작업하기가 더 쉬워질 것입니다.

글꼴 디렉토리는 대소문자를 구분합니다… 89sabers의 기본 구성 파일에서 대소문자가 일치하지 않는 일부 불일치를 발견했습니다… 예를 들어 luke와 Luke.

Thank you for your reply. Sincerely. First, I asked the seller for the original file. By the way, if you don’t mind, can you please share the file? ㅠㅠㅠ im sorry

This is my first Saber… Chassis refers to the board, right? Does pommel refer to the saber body? ㅠㅠ I’m worried. The seller’s file is suspicious. If you don’t mind… Can I get a copy of your files? If Jae isn‘t breaking any rules…

If your Soundboard is using ProffieOs7 it needs a common file, you can download it or get more explanation here:

If you want to just download it you can get it from here


1 Like

The chassis is the internal “tube” were the soundboard is. The pommel is the bottom part where you access/extract the chassis.

1 Like

Maybe this will help:

1 Like

Do you have to pay for everything like fonts and sounds???

I want to get cal’s sound font and effects, but I‘m searching.

thank you! This was helpful!

There are free fonts available, but most you have to pay for.

Some free fonts can be found here:

You can download the standard 89sabers proffie configuration file from ccsabers website.

Your installer may have added sounds to the SD card. You should compare the folder names on your sd card to those listed in the files from the link above.

I couldn’t see the top of your chassis in the video. Can you confirm it is the 89sabers universal chassis? They have a 13 pin connector at the top. Your kill switch seemed to be in a different place than i expected.

I will send my corrected version when i can… im traveling this week.

Still has an update pending, right? :wink:

I’ll re-upload the photo! I’m off to work nowㅠㅠ I’ll upload it when I get home!


(more characters)

I went back and compared the 89Sabers stock config file to my original SD card backup. The only issue was with the “Luke” soundfont. The stock config has “luke” and the SD card has “Luke” so you should be able to duplicate the “Luke” folder on your SD card and name the copy “luke” which should fix it–if your error was the same as mine. You didn’t mention who you got it from, so it is possible your installer used a different config and has different sound fonts–and different problems.