How to flash board without manually putting the board into boot loader?

so, I’ve installed everything and followed the proffieOS setup to the letter, yet I still have to manually put the board into bootloader, I also get this error every time I open proffieOS “Error downloading
Error downloading” I’ve tried troubleshooting on the r/lightsabers discord server and people who tried to help me were stumped, and I was told to come here and see if the issue could be resolved.

Maybe try this:

  • (In the Arduino IDE) File > Preferences
  • Click the link at the line following “More preferences can be edited directly in the file”. This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files in that folder except for preferences.txt.
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.

There’s some folders in arduino15 As well called cache, packages, and staging, should I delete those as well?

Still says error

Ok i updated arduino and I’m reinstalling everything so hopefully it works this time

It didn’t work

I think there are two separate problems going on here…

Did you select the right port in Arduino → Tools → Port?

This would seem to be an Arduino problem.
Do you have internet access on this computer?
If you put that URL in a browser, does it work?
Is the clock set correctly on your computer?

There is only 1 port available, being COM1

And the second issue was resolved by installing the newest version of arduino

There is only 1 port, which is com1

Does it say Proffieboard (or Butterfly) next to it?

No, it just says com1, that’s all it says

That’s not the Proffieboard serial port then. (I’m guess that it also shows up when the proffieboard isn’t even connected.)

Is it possible that you have run Zadig incorrectly?
Please watch this video and see if it helps you:

Omg it worked, THANK YOU SO MUCH DUDE!!!


Well, it fixed it for one of my sabers, I’ll need to check the other two

It fixed the other two as well, thank you so much dude!