Help please

Hi all and Fredrik,

I’ve got an issue with a new saber I purchased that’s got a Proffieboard in it.

It’s an LGT saber so nothing flash, but none the less it should work.

It was fine out the box, but I reflashed the board and added new fonts and it just won’t work.

I’ve done this hundreds of times on loads of different proffies so I’m competent at it yet this time it’s just not working.

I’ve gone through 3 SD cards and the issue persists.

It’s telling me constantly there’s an error in the aux directory. I’m using 2 fonts I’ve used again hundreds of times, both made by Kyberphonic, neither ever had an issue. I’m also using the common folder downloaded from Frederiks website.

Secondly, between fonts, if I hold the button to switch them I get a 20-30 second delay until it switches.

It’s sporadically unresponsive and I have no idea why.

When in a font it works just fine, but it struggles switching between them and keeps telling me I have an error.

I have no idea what to do about it and I’m loosing patience at this point …

I’m running OS6.7 and the sd is flashed to FAT32.

Sluggish performance could be a slow SD card.

Start from scratch. Set up a config with just one font you know works, then add one that doesn’t. Also, share your config.

1 Like

So I’ve made some progress thanks to Brian Connor.

The problem is the common folder.

With it in situ, nothing loads, everything is massively delayed. I’ve formatted the SD card, downloaded a fresh set of voices for the common folder from Fredriks website and it still persists.

The second I delete the common folder and the link to it in the config everything fires up perfectly and works as normal?!

For instance

“Rey;common” - breaks the saber, doesn’t work

“Rey” - is absolutely fine and everything cycles fonts no problems.

So the problem is the common folder; the annoyance is, it’s a fresh formatted card, I’ve tried 3 different ones and everyone has the same issue.

Are the files on fredriks site corrupted perhaps? Or is OS6.7 broken with the common folder?

Did you add the language files?

The voice prompts?

If so, then yes English pack C (the female voice)

Try running sdtest all.
What does the results look like?
Do you see any slowdowns during the run itself?

Did you see my second post in this topic, just curious if that negates this now ive found that the common folder is the one causing the problem?

If it still helps, ill run the sdtest all

sdtest all will read every file on the SD card, including the ones in the common folder.
Lots of people are using a common folder with no major issues though, so the question is what is different in your case.

My guess is that there is something wrong with the common folder. This could be because of a bad SD card, an interrupted write operation, or maybe a lot of extra files?

However, it could also be a hardware or software problem somewhere causing this, but that’s harder to find and fix, so I figure it’s best to test and exclude the easy things first.

gotcha, just uploading the files back to the sd and then ill run sdtest all and upload results here in 5 minutes

its just doing it now, but there are 48 fonts, so is it going to run this cycle for all 48? - if so could be a while … and be a large text file when done too!

Okay so while ive been waiting, ive got all my fonts back uploaded but NO common folder.

Works perfectly.

So I added a common folder and it was empty. Still worked perfectly.

So I added voice pack English C, problems came back.

I deleted voice pack English C, problems went away.

I added voice pack English F, still worked perfectly.

So looks like English Voice Pack C via the proffie website may have corrupted perhaps? - Needs investigating either way.

That’s very helpful, I will check out voice pack C tonight.

All the files in voicepack C look ok to me.
Comparing the files in the C and F voice packs, I see that the C voice pack is missing these files:

The C voice pack does have these files files that voicepack F doesn’t have:

Not sure if the missing/extra files are the problem, but it should be easy to test by adding/deleting these files.

1 Like

I will thoroughly investigate all this when I get back in town.
It’s weird.

Just for clarity, another guy posted on the Facebook groups with SD card errors and issues with the common folder.

It transpires he too was using voice pack C and when he stopped using it the problems went away.

So is this still an issue? It seemed pretty conclusive that a fresh download of English C was causing issues. Now…?

I tried file pack F instead and all worked fine.

Went back to C and broke again. Back to F, fine again.

So I think file pack C has issues (as 2 people in a week have reported it now).

No idea what’s wrong as I couldn’t see anything off in the files I downloaded, but for some reason the proffie didn’t like it.

May I ask a favor then?
Please try THIS version of English C and see if there’s any different results compared to the downloaded version you had issues with:

1 Like