Help fixing new saber

So I just received my new (proffie) fulcrum sabers from pachstore. The shorter one works good, but when I first tried to turn on the second one I got the sd card not detected error. I went to look at the sd card and it seemed to be cracked in half, and fully broke apart as I tried to take it out. I then went and bought another micro sd, and copied the files on the sd from my smaller saber and put them on my new sd card, however I am still getting the same error message. Any ideas how I can fix this?

some photos of the SD slot on the board might help? It could be that whatever caused the card to snap put pressure on the slot as well. This is likely an issue for the vendor to sort out.

I thought of that as well but that’s not the reason because I took the sd card from the smaller saber and it worked perfectly in the larger one.

Does the one you copied work in the smaller one?

nope i get the same error in both for the new card

1 Like

Talk to the seller and have them fix it?