Help! dfu error

I am coming up with a DFU error message that I have never had before when adding to my lightsaber. The only thing different with my PC in the past 2 weeks was I install Microsoft flight sim 2020, I am hoping this did not mess up any drivers. I am a NOOB with this, I greatly appreciate any help with this.

Here is my pastebin:

So, normally, this error means you need to run zadig.
However, if it has worked in that past on this PC, then that shouldn’t be the problem. However, I know what some controller drivers take over the DFU USB IDs and replace them with a “guillemont” driver. Did you install drivers for some sort of flight controller maybe? (Or maybe MS flight sim 2020 did that for you?)

There are a few things to do: (and let me know if you need help with any of them)

  • check what driver is being used for the “STM32 BOOTLOADER” device.
  • un-install whatever driver is being used for it right now.
  • re-run zadig

This is the order I would do them in, but re-running zadig might just solve the problem, so you could start with that.

Sorry Fredrik
Im not sure how to delete. This is all I can see.


So this is definitely a controller thingy interfering.
I think the right thing to do is to go into Settings → Add/Remove programs and find the controller software and uninstall it.

Controller for the flight sim joysticks?

I also tried to re run zadig, and still getting the DFU error


Unfortunately, the guillemont software tends to reinstall it’s own driver association, so running zadig doesn’t really “take”.

It may be possible to work around it, but it’s not particularly convenient, basically you go through all the steps of running zadig, and then you hit upload before disconnecting the board. (Note, you won’t see a port in Arduino, but it should still work.)

The inconvenient part is that you would have to do this for every upload.

So I woke up and decided to fight with more error messages. Could you please advise what might be wrong?

It looks like you inadvertently removed the opening /* for the comment block at the top of ProffieOS.ino.
Look at the top lines of the file in Arduino.
It should be

 ProffieOS: Control software for lightsabers and other props.
 Copyright (c) 2016-2019 Fredrik Hubinette

Oh perfect. I must have totally done that by mistake. Thanks so much, I copy/pated what you posted and all is working now.
Thank You NoSloppy!!

1 Like