Guide to videotoblc?

Was looking into adding an audio visualizer bladestyle to my saber, was told about video to blade color, but I cannot seem to find a ‘tutorial’ or a guide.

Anyone know how to set it up?

Let’s start with the information that is already available out there:

Not a whole lot I admit, but maybe I can write a pod page about it this weekend.

1 Like

that would be helpful. I’m looking at the thread but I’m not really getting how to set up the whole thing.

Well, in short, you need to:

  1. compile videotoblc
  2. install ffmpeg
  3. get or make a video file that has the blade animation you want
  4. run videotoblc to convert it to a blc file.
  5. Put the sound that goes into with the video into hum.wav in some font directory on your saber.
  6. Put the blc file into the same directory as “hum.blc”
  7. Create a style that uses FromHumFileStyle, and blade will be synchronized to the music in the hum.

I don’t know if videotoblc will work on windows, but it will definitely work in a linux environment running on windows, or on a Mac.

Ah, didn’t realize it was a linux thing. I’m completely out of my zone with mac or linux. Would i need to run a virtual machine of sorts?

It’s probably not difficult to get it to work on windows. Probably the only thing that needs to be fixed is to make sure that popen uses binary mode, which I think is relatively simple.

I haven’t written a page for this yet, but I did find this page:

It shows how to get the POV tools going on windows.
Getting videotoblc going should be similar, except of course some of the particulars is different.

got POV functioning and it works well. To progress with VtoBLC i need ffmpeg, where could i find the specific download?

Edit: got ffmpeg installed, now i have to get VtoBLC installed. Gonna figure that out now

If you’re on Windows I’d presume you’ll want to use Powershell, possibly run as administrator.
If you want to, check out my Mac experience setting it up. It might help in some way.

I’m still a bit stuck on the videotoblc side of things, even though I got POV working. My issue seems to be that, in the POV tools folder theres a .win file, which I needed to run to generate the image for the bladestyle.

However in the videotoblc file all I see are some .h files, a regular file, and a .cc file, none of which I can run. I’m supposed to ‘compile’ something but I’m not really sure what or how.

already got this set up for POV, can’t imagine its much different.

The videotoblc directory doesn’t have any handy scripts to make things easier.
Instead you must open up a command prompt (bash, powershell, whatever) and type in:

videotoblc video.mp4 >output.blc

(Assuming your video is called video.mp4 and you want the output to be called output.blc)

ah, ok. And is there a specific resolution, framerate, etc i should be aiming for?

Not really. But you’ll need to know the framerate when you configure the blade style later.

videotoblc : The term 'videotoblc' is not recognized as the name of a cmdlet, function, script file, or operable
program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ videotoblc robotaki.mp4 >robotaki.blc
+ ~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (videotoblc:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

little confused… am i supposed to route it to my specific videotoblc folder in my proffieos?

The only files i have in videotoblc are these:
MakeFile (file)
matrix (.h)
thread_helper (.h)
timing (.h)
videotoblc (.cc)

not really sure what to do with them, and my powershell doesnt seem to recognise them either.

Im thinking that it’s not able to use the videotoblc code in proffieos because it can’t access the ffmpeg, but i’m not entirely sure how to connect the paths. I know that you were able to do it on mac but its probably different on windows

DId you cd to the videotoblc folder first? If not you’d need to include the entire path to the files (not recommended).
You need to be in the ProffieOS/videotoblc directory in your command line console.
Your video file should be in the same directory.
Then videotoblc videoFileName.mp4 >output.blc

I keep attempting to cd the videotoblc folder in proffieos but i keep getting the same response:

C:\Users\orang> cd [C:\Users\orang\OneDrive\Desktop\proffieos\OS7.X ALPHA\ProffieOS\videotoblc]
The filename, directory name, or volume label syntax is incorrect.

Try it without the [] and without the C:
Just: cd \Users\orang\OneDrive\Desktop\proffieos\OS7.X ALPHA\ProffieOS\videotoblc

I suppose it may need quotes since there are spaces in there:

cd "\Users\orang\OneDrive\Desktop\proffieos\OS7.X ALPHA\ProffieOS\videotoblc"

that seems to have worked, but when i try to run the videotoblc videoFileName.mp4 >output.blc it still gives me 'videotoblc' is not recognized as an internal or external command, operable program or batch file.

Is it still not reading with ffmpeg?