Graflex Eco CC Configuration

Hello - Trying to get LEDs to light up on Eco CC Graflex from KR Sabers. Everything is wired up, but getting sound and no lights. Using below baseline BladeConfig via Fett263

BladeConfig blades[] = {
 { 0, WS281XBladePtr<132, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3> >(),
    WS281XBladePtr<1, blade2Pin, Color8::GRB, PowerPINS<bladePowerPin1> >()
  , CONFIGARRAY(presets) },

To eliminate the possibility that the issue is a bad configuration, wanted to see if anyone has a BladeConfig for Eco CC Graflex that is known to work. Wondering if maybe our Power Pin defines are off.

Also, can anyone advise what voltage should be drawn from the LED driver pins when they’re supposed to be powered on? Thanks :slight_smile:

The blade config looks reasonable, and should at least generate something.
That probably means that this is a hardware/wiring issue, which means you need to check with a multimeter if power and data is getting to the blade.

3.5 to 4.2 volts

Thanks for answer. I would expect that the LED driver pins would be putting out a low voltage since the other side of the LED is hardwired to BATT+. If the LED driver is putting out battery voltage then the LEDs won’t turn on. I was thinking closer to zero Volts since the FETs should pull the pins all the way down. But I’m a newbie so there’s that…

What I meant is that the voltage between BATT+ and LEDx should be 3.5-4.2 volt when on. If you measure between a LEDx pad that is on and GND, you should see less than 0.04 volts.

1 Like


Circling back, still trying to narrow down why we’re getting no lights from the main NPXL connector/blade.

For Eco CC Graflex chassis, I have crystal LEDs wired in parallel to Data2 and LED4 on the board. NPXL connector/main blade are wired to Data 1 and use both LED2 and LED3 on the board.

From what I can tell on below setup, bladepin for my 132 LEDs of the main blade corresponds to Data1 on the board, and blade2pin for my single accent (two accents for the Eco CC chassis wired in parallel) corresponds to Data2 on the board. So that piece looks right from what I can tell. Am I missing something? The crystals light up but the NPXL PCB/blade.

Or does anyone have the KR Sabers Graflex Eco CC chassis who can share their code that is known to work? :innocent:

BladeConfig blades[] = {
 { 0, WS281XBladePtr<132, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3> >(),
    WS281XBladePtr<1, blade2Pin, Color8::GRB, PowerPINS<bladePowerPin1> >()
  , CONFIGARRAY(presets) },

Have you discovered if it is the power or the data that is the problem?
Have you tried a different blade?

I want to say the power’s not the issue if the crystals in the Eco CC chassis are lighting up and we’re getting sound. So I think it’s either a data issue or a bad neopixel connector.

Haven’t tried a different blade, but I assume if there’s no LEDs lighting up on the NPXL connector, then it likely won’t show on the blade.

I have it that ‘bladepin’ and ‘blade2pin’ in the configuration correspond to Data1 and Data2 respectively on the Proffieboard. Is there labeling I should look for in the code that corresponds to LED2/3/4 on the board as appropriate with our wiring?

I don’t mean power in general, I mean “power to the blade”.

This is correct.

bladePowerPin1 corresponds to LED1, bladePowerPin2 corresponds to LED2, etc.

Hmm the accents light up but they’re wired to LED4 on the board, meanwhile their configuration had LED1 defined. Am I missing something?

Other than that, the neopixel connector/blade use Data 1 and LED2 + 3 on the board, which are both defined in the code, so that piece appears to be correct(?)

This could mean one of two things:

  1. the accents are stealing power from the data line to light up. (This shouldn’t be happen if you have a resistor on the data line though.)
  2. The program running on your saber isn’t actually the one you think it is. This can happen in at least three ways:
    2a. ProffieOS Documentation: Is it uploading?
    2b. The CONFIG_FILE specified in ProffieOS.ino is not the one you’re actually editing. (For instance, you could be editing mysaber.h.h, but ProffieOS could be using mysaber.h, this can be confusing on windows in particular.)
    2c. If you have multiple ProffieOS directories on your computer, make sure that Arduino and you are actually working in the same one.
    All of these options can be detected by making an obvious change in your config file, uploading and make sure that that change is present on the saber.
  3. (I’m good at counting) something odd is going on with the wiring.

Turns out it was 3 - we weren’t wired to Data1 on the board :laughing: - off by one wired to Free3