Functioning proffie not recognized by computer

I have a fully programmed and functioning board in a removable chassis that will not be recognized by my computer. Using the same cord and port 3 other boards connect fine. I have deleted and redownloaded Arduino and all applicable files. Any ideas as to why or how to fix would be much appreciated. I NEED to finish this crimson menace!

Has it ever connected?
Who did you buy the board from?

  1. mac, windows or linux?
  2. when you say “recognized by your computer” how do you check?
  3. Have you tried BOOT+RESET?
  4. Have you tried checking Devices & Printers?
  5. Even though the cable seems fine, you might still want to try a different one. Sometimes USB connectors have minor defects that make certain combinations of connectors work poorly together. (Although, this is fairly unusual.)

Yes, it has connected and updated several times in the past. It just started this

I’m using Windows. When I say recognizes it tones for connection then a 3 count and disconnect tone. As long as the board is connected to any usb port with either of 2 cables this connect/ disconnect tone pattern continues. When I was able to catch the pop up it said error unknown usb device. I bought the board from Dark Wolf as a programmed unit , I have had zero issues updating and modifying it in the past. When I press Boot+Reset it stops the connection tone pattern but is still unrecognized usb device. I’m baffled!

The tones come from the computer not the board.

Hmm, this does sound like there is a problem.

A few tips:

  • Don’t rely on the window connection sound, there are times when it doesn’t trigger for some reason.
  • A bad programming can make the board behave very badly, which can confuse windows a lot.

The solution to both of these issues is the same:

  1. connect the board to the computer
  2. hold BOOT, press and release RESET
  3. Check Start Menu->Control Panel->Devices and Printers the board should show up as “STM32 BOOTLOADER”.
  4. If the board shows up, you can hit upload in Arduino (no port required) and the board should recover from the bad programming.

If the board doesn’t show up after step (3) above, then one of these things must be true:

a. Board is broken
b. Cable is broken
c. Computer is broken

SInce your computer works with other boards, that’s not the issue. Since the cable works with other boards, that is unlikely to be the issue.

From your description, it sounds like you’ve already tried these steps, and the board shows up as “Unknown USB device” rather than “STM32 BOOTLOADER”. When this happens, it means that windows can detect that something is connected, but is unable to actually talk to the device.

To me it sounds like you need to get in touch with the seller and see if you can get a replacement.

Replacement ordered. I was just hoping to be able to fix and avoid a chassis rewire. Your assistance and advise has been much appreciated.

It shows up once boot/reset . But, it shows up as unknown usb device (device descriptor request failed).

Try just flashing the board when that happens.

How do I flash the board?

Press the upload button in Arduino.

Arduino doesn’t recognize a connection and does a 10 count failure to upload