Fried Proffie - troubleshooting components

Hello folks.

I was just finishing up an install now and potentially fried my board. There was an exposed strand of wire from LED2/3 which contacted the hilt casing and I’m pretty sure has fried something or other. I took the battery out immediately but the board got very hot and smoked a little, and I can smell burning.

My multimeter skills are fairly rudimentary and I’m not sure how to isolate what I’ve damaged in order to see if it can be repaired. I will describe the symptoms below in the hopes you might have some ideas.

-Speaker works but is crackly and distorted. Have tried swapping out the speaker with no change. Battery is fully charged
-Power switch does not work, nor do gesture controls, which should be enabled in the config. Can’t verify if the NPXL connector functions or not as I can’t get the saber to power on at all. Interestingly I’m reading continuity between the power switch pad and GND without the switch being depressed. Is this normal, or is something shorting somewhere?
-Aux switch functions normally, as do the crystal chamber accents.

I’m hoping I can salvage this by maybe moving to other pads, but I’m not sure what to test or how to do it to be quite honest. Any help would be much appreciated!

This might help:

(Please note that if your browser tells you that the site is dangerous, it’s because google is repeatedly mistaken my driver installer for malware, and apparently, my site is guilty until proven innocent.)

Hey Fredrik, thanks for the response.

I’ve taken the build apart and discovered the LEDs and power switch do function, I think there was just a short inside the hilt somewhere. The only issues currently are the speaker noises which are crackly and distorted (blown amp?), and I believe the Proffie is not detecting motion. How would I go about testing this?

For scratchy amps, check if the 5v pad has 5 volts or not.
Usually, you can see if motion is working or not by checking the serial monitor.

The serial monitor of the motion chip seems to be working fine.

I’m having a hard time testing the 5v pad as the blade won’t remain ignited for longer than a second or two - the Proffie seems to be reading the battery as being critically low and shuts off. I’ve tried this with two fully charged batteries with the same result. What would this indicate?

Just throwing this out there, but are you sure you didn’t inadvertently upload the wrong board plugin?
Arduino menu Tools>Board>Proffieboard>Proffieboard (is a v1.5 board)
as opposed to Tools>Board>Proffieboard>Proffieboard V2

Hey NoSloppy, double checked just now but I did indeed use the v2 plugin

Not normal, sounds like bad switch. can you test the switch isolated?
If it’s good, you can try just moving it to button 3 instead, then change your CONFIG_BUTTONS to

Button PowerButton(BUTTON_POWER, aux2Pin, "pow");
Button AuxButton(BUTTON_AUX, auxPin, "aux");

Also, what does Serial Monitor say?
Can you send on, blast, off etc… and have it behave accordingly?

Yeah the switch issue was caused by a short against the hilt casing. I took everything out of the hilt and It works normally now, as does the blade and connector. All functions seem to work in the serial monitor with no issues, including the accel and gyro commands.

The only issues now are the sound output (I’ve tested two speakers with no change) and the battery reading as critically low despite being fully charged. I’m suspecting a blown audio amplifier or maybe the regulator or booster?

Well now that you can keep power, do you have 5V on the 5V pad when the blade is on?
If not, that would indicate a bad booster, and then you can try jumpering the 5V pad to the BATT+ pad, which should clear up the sound at the sacrifice of slight bit of volume.

Not sure what the low battery reading might be.
What does serial monitor report the battery level is?

The 3.3v regulator is U60, the 1x1 chip next to the 3 power diodes.
The output leg is the bottom right, when looking at it like this part map, and directly feeds the top of C6 or the BOOT switch if you want to check for 3.3v. Also, the SD power pad or 3.3V pad should all be the same result.
IF the regulator were bad, the CPU would likely be unhappy though, but :man_shrugging: