Free pad not working as Blade Detect


I am using Free2 as the blade detect pad and for some reason it is not working? I have tried a different pad, data 3, and it worked fine. My define for Free 2 is:


Any ideas?

Seems like it should work, unless Free2 has been damaged in some way.
When it’s configured with blade detect on Free2, can you measure AC voltage on Free2? (when not connected to anything)

I can try, But I am installing 20 boards right now and none of them Are working, so unlikely it is damaged. I am going to try on Data 4 since that would be an easy fix if it works. But I was just making sure there no reason the free pad would not work for detect.

Post your config file?
I can give it a try here and see how it behaves.

I just tested it with Data 4 and it worked. So i really dont know…

I ran your config file on my test bench.
I can measure the high-low pullup signal from Free2, and when I short it to ground it says “font directory not found”, which is expected.

It’s a fairly basic test, but it seems to work as intended.

Man that is weird. I’ll run some additional tests myself to see if I can replicate. Thanks for looking into it.