First Proffie build, The port Won't show up in IDE2.1.1

I just built up my new proffieboard today, I followed the instructions for the ‘port menu’, but the COM port won’t show up in IDE2.1.1. the driver number and Zadig driver look right to me. I really don’t know what to do next.




I followed the Configurator for wiring my proffieboard, but not sure if all are installed correctly. Is there a way to check if the motherboard is working properly?

When I installed the battery, the positive electrode of the battery became hot, I didn’t know what was going on :smiling_face_with_tear:, so I removed the battery immediately for safety reasons…

If the board shows up as STM32 BOOTLOADER in zadig, then it is at least working well enough to be able to be detected over USB, which means that you should get a port if the board is programmed correctly.

If the board is not programmed correctly, you can still upload without a port, you just put the board in bootloader mode and hit upload. After that, the port should show up.

The short that caused something to heat up is something you need to fix though. I recommend measuring the resistance between + and - before putting in the battery. If it’s too low, you have a short and you should not put the battery in. Also, make sure you’re putting in the battery the right way.

It’s possible that something was damaged when the battery heated up, but like I said, it sounds like the board is working well enough to talk USB at least.

PS: Go easy on the screenshots. The picture of the wiring is super helpful, but the others really don’t add much. (We don’t need to see your menu, if you say it doesn’t show up, we trust you… )

thanks for your reply, pray: I tested the resistance between the battery + and - and it was very very low, something is wrong with it, and I don’t quite understand. but as you said, the board is working well enough to talk USB at least, it’s good news for me.

Okay, I got it~


Can you see where the short circuit happened? Dose LED2-3 pads need to be bridged?

I don’t see the short, but the first thing I would test is if the power plug is wired right. I’ve wired those things wrong more times than I care to admit… It’s also the only point where + and - nearly meet up.

Also, what do you mean by “very low”? (I think ~10 ohms is fairly normal, but it tends to depend on which way you measure. Try switching the leads around and see if you get a different value, if you do, take the higher of the two.)

Hi, Prof~I’m making some progress, just let you know. I reflashed the board with OS6.9, and now I’ve got port COM4. I did not use the DC charging port and completely rewelded the proffieboard. but here comes the tricky part…the board works great when the USB powering. the speaker is working great, while inserting the battery the speaker is working much better. But when using battery power it said font directory not found, SD card not found, Only LED can light up. I have tested the battery is 4.12V, and between BATT+ and GND is 3.12V, and the battery contacts are 4.14V. I don’t really know what’s going on :smiling_face_with_tear:. Could it be a welding or wiring problem that caused the voltage drop? because I don’t trust my wiring and welding techniques…

There are a few possibilities for voltage drops like these:

  1. Bad battery
  2. Bad connections/soldering (cold solder joints can have high resistance)
  3. Shorts, or something else that is drawing a lot of current.

Here is what you can do to narrow it down:

  • Try a different battery
  • Try measuring +/- on the battery while plugged in (is it different than BATT+ ↔ GND ?)
  • Check if anything is getting warm (or hot)

I rechecked the pads that I thought were of poor soldering quality and re-welded, inserted the battery and sd card, and the led on pcb are lighting up and sound quality were perfect. I was very excited about it. So I move on and tried to install it in saber. But after installation, I inserted battery, the board is getting hotter (FET & “+”battery),also a lillte smoky , and I saw red light flashing on board. I am very frustrated, but I will not give up, I have a few boards left , but I have to check the cause…

I admit I was too impatient and need to take it slow next time…

The most common cause for FETs to heat up is a short in/near/around the pogo pin PCB.
(It could be somewhere else of course…)

EVENT: Power-Pressed ON millis=10960
EVENT: Power-Held#1 ON millis=11261
EVENT: Power-Held ON millis=11261
EVENT: Power-Released#1 ON millis=11288
EVENT: Power-Released ON millis=11288
EVENT: Power-Shortclick#1 ON millis=11288
unit = 1 vol = 0.50, Playing Graflex/in01.wav
channels: 1 rate: 44100 bits: 16
No sounds found: pstoff
Unmounting SD Card.
Amplifier off.
EVENT: Power-Pressed#1 millis=15545
EVENT: Power-Pressed millis=15545
EVENT: Power-Released#1 millis=15781
EVENT: Power-Released millis=15781
EVENT: Power-Shortclick#1 millis=15781
EVENT: Power-Shortclick millis=15781
unit = 0 vol = 0.00, Playing Graflex/hum01.wav
channels: 1 rate: 44100 bits: 16
unit = 1 vol = 0.50, Playing Graflex/out01.wav
channels: 1 rate: 44100 bits: 16
humstart: 1800
unit = 3 vol = 0.00, Playing Graflex/swingl02.wav
channels: 1 rate: 44100 bits: 16
unit = 2 vol = 0.00, Playing Graflex/swingh02.wav
channels: 1 rate: 44100 bits: 16
Playing Graflex/swingh02.wav
channels: 1 rate: 44100 bits: 16
Playing Graflex/swingl02.wav
channels: 1 rate: 44100 bits: 16
EVENT: Power-Pressed#1 ON millis=18585
EVENT: Power-Pressed ON millis=18585
EVENT: Power-Released#1 ON millis=18875
EVENT: Power-Released ON millis=18875
EVENT: Power-Shortclick#1 ON millis=18875
unit = 1 vol = 0.50, Playing Graflex/in01.wav
channels: 1 rate: 44100 bits: 16
No sounds found: pstoff
Unmounting SD Card.
Amplifier off.
Battery voltage: 0.03
Booster off.

Hi, Prof~ sorry to bother you…I tried to build it again but I felt the D61 broke again. Because I can’t use battery power … this time I feel the STM32L is getting hot. but this time I tested the +/- on the battery is 4.13V, and BATT+ ↔ GND on board is 4.12V.the results are much better than yesterday…but still, the SD card is not found. I wired everything up but pogo-pin[+, -, Data].

This is my wiring diagram, dose it make sense to you? I just feel strange…Why does it keep going wrong. Maybe the drawings are the reaso.

I have fixed up my saber using a new proffieboard, I made sure to CONNECT ‘‘GND’’ and ‘‘BATT -’’ and soldering to two pads. everything works great. Thank you, Prof, :pray:for your guidance, really appreciate it. Next time I’ll try to install an empty hilt. :mechanical_arm: