File downloads successfully but…

Hello, I have just finished wiring up a new board, v2.2. To test it out I used a working config and corresponding sd card loaded with fonts matching said config. I opened Proffie is 6.7 and selected port COM7(Proffieboard). After download transition to dfu manifest state but get “ directory not found and sd card not found. I have a window that keeps popping up that says, “directory name is invalid E:\”. I also cannot eject the proffieboard as the computer does not see it. I have tried boot reset and also downloads ok but get the same results as above.
Please advise

I’m going to read between the lines a little here…

  1. You probably did not select “mass storage” in Arduino → Tools → USB type, which would explain why windows doesn’t windows doesn’t show a drive for you to eject
  2. I’m guessing that you did not eject the drive before programming, and windows is still trying to do something with E:\ when it suddenly went away.
  3. If it’s saying “SD card not found”, then maybe the SD card got corrupted when you programmed it without ejecting first…

Steps to recover:

  • Choose one of: format the SD card and put all files back from a backup, or try “repair” on the sd card and see if that fixes things.
  • If you do enable “mass storage” in Arduino → Tools → USB type, make sure to eject the drive before disconnecting OR programming. Alternatively, don’t enable “mass storage” and use an SD card reader when you want to modify the contents of the SD card.

Profezzorn, I will check out your fixes and get back back, thankyou.

USB Type: “Serial+Mass Storage” was selected.
I formatted the sd card and installed fonts and common folder . Opened OS and started upload. Window popped up “ Error during special command “ERASE_PAGE” get status. Removable Disk (E) keeps piping up also.

Also made sure I ejected sd card properly.

Well, windows will also fail to show the drive if the SD card is broken or if the data on it is sufficiently corrupted, so format/repair/replace the SD card still applies.

I will now try another micro sd card, hold on please

Solved, I tried another micro sd card and config downloaded properly and I was able to eject the Proffie board. Thankyou profezzorn.

1 Like