Error message not sure whats wrong?

Arduino: 1.8.19 (Mac OS X), Board: “Proffieboard V2, Serial, SDCARD (SPI), 80 MHz, Smallest Code”

In file included from /Users/Joa/Desktop/ProffieOS/ProffieOS.ino:563:
/Users/Joa/Desktop/ProffieOS/config/myconfig.h:104:2: error: expected ‘}’ before ‘;’ token
104 | };
| ^
In file included from /Users/Joa/Desktop/ProffieOS/ProffieOS.ino:563:
/Users/Joa/Desktop/ProffieOS/config/myconfig.h:43:20: note: to match this ‘{’
43 | Preset presets[] = {
| ^
In file included from /Users/Joa/Desktop/ProffieOS/ProffieOS.ino:563:
/Users/Joa/Desktop/ProffieOS/config/myconfig.h:104:2: error: cannot convert ‘’ to ‘const char*’ in initialization
104 | };
| ^
exit status 1
Error compiling for board Proffieboard V2.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

Also, is there somewhere that I should go to reference for errors or like learn about this instead of bugging you guys whenever I have a problem?
myconfig.h (19.6 KB)

there is two os6 fonts in there and when I remove them everything works fine so are you not allowed to have older fonts with new ones?

Your preset for Ra is missing the closing part of the preset.
It ends with a comma, but it should end with something like this:

...........,Black>>>(), "ra"},

just like all the other presets.

Here’s info on errors, and a video of how to find and fix.
If you still need help, asking is actually encouraged here.
Others can then learn as well from the conversation :slight_smile:

Okay that fixed the compiling but now when I upload it to the saber and turn it on it says ~something something not found" not sure what the first words are but I will attach a video

Okay so it was the font directory not found but I don’t understand how to fix that the names are the same on the sd and in the config and they are definitely on the sd so what am I doing wrong?

EDIT: I took out the DBZ font from my preset and now it works I think that there was something wrong with the font because I randomly found it on my mac

If it said “not found” then it couldn’t find it.
If it said “Error in Font Directory”, that’s different, and usually means you have a sound out of sequence, like clsh01, clash02, clsh04… missing #3 will throw that error.

Ohh okay thank you.
Unrelated question but how tight do you make your retention screws?
I have a crimson dawn dragoon and I put all 4 screws in and make them tight enough till I hear a cracking sound and they still don’t last that long and I’m only really doing light spinning. I am going to Ace tomorrow to get all long screws because I notice that the short ones come out really fast and that messes the whole thing up. Would be great to know how other people deal with that. Thanks!

maybe you’re overtightening.

how would I know what is the right tightness is?

Just enough so it doesn’t fly out when swinging? Get pointed tip ones. They bite into the polycarbonate blade and don’t need to be so tight.

1 Like

ahh okay, I was thinking about that but then I didn’t want to screw them in and crack it too much or something then end up damaging it.

I’ve had this problem a few times and have tried reformatting the SD card and doing a clean file transfer with no success. The last time it happened was on an OS 6 upload and there was a looooong pause before “font directory not found” played right over the boot sound. So like you I deleted a font. But when Kyberphonic’s Bandit (from The Duel) font suddenly went from working to not working I thought it must be something else I’m doing wrong. I replaced my SD card with a higher quality brand new one from the suggested list in the manual.

All of the fonts now work fine. I hope that might work to keep your DBZ font going.

Cables and SD card should be bought in bulk :slight_smile: