Error in font directory

I keep getting an “Error in font directory” no matter what I do. I own several proffie sabers and have uploaded custom configs and blade styles many times and have not had any issues. However I recently attempted to update one of my proffie sabers and tweak a few blade styles and have been plagued with an “error in font directory” ever since. I even went as far as to upload an extremely basic config with only one blade style and sound font and still got an “error in font directory”. I thought maybe my sd card was bad so I swapped it out with a new one and still no change. I even tried to roll back to the previous OS version and config that I had before I messed with anything and Im still getting an error in font directory. I am doing all of this on a Mac…any chance its my computer messing something up in the file transfer to the SD card? Im honestly stumped and beyond frustrated.

1 Like

can you provide the following:

the config you are using


config here

in addition can you provide a list of the folders on the sd card.

check to see if the sd card can be read.

Remove DISABLE_DIAGNOSTIC_COMMANDS define from your config.


With saber connected go to Arduino > Tools > Serial Monitor

Type ‘effects’
on the preset giving error and it will output the errors so you can resolve.

1 Like
// ProffieOS7 Config File
#include "proffieboard_v2_config.h"
#define NUM_BLADES 2
#define NUM_BUTTONS 2
const unsigned int maxLedsPerStrip = 144;
#define VOLUME 1500
#define ENABLE_WS2811
#define ENABLE_SD
#define MOTION_TIMEOUT 60 * 15 * 1000
#define IDLE_OFF_TIME 60 * 15 * 1000
#define ENABLE_SSD1306
#define FETT263_LOCKUP_DELAY 200

#include "../props/saber_fett263_buttons.h"


Preset presets[] = {
{ "Cal;common",  "Cal/tracks/JFO4.wav",
/* copyright Fett263 FallenOrder (Primary Blade) OS7 Style
OS7.12 v1.017-p
Single Style
Base Style: Fallen Order Cal Kestis

Base Color: BaseColorArg (0)

--Effects Included--
Ignition Effect: Standard Ignition [Color: IgnitionColorArg]
Retraction Effect: Standard Retraction [Color: RetractionColorArg]
Lockup Effect: Intensity Lockup V1, Begin Effect: Real Clash, End Effect: Full Blade Absorb [Color: LockupColorArg]
LightningBlock Effect: Responsive Lightning Block [Color: LBColorArg]
Drag Effect: Intensity Sparking Drag [Color: DragColorArg]
Melt Effect: Intensity Melt [Color: StabColorArg]
Blast Effect: Blast Wave (Random) [Color: BlastColorArg]
Clash Effect: Real Clash V1 [Color: ClashColorArg]

/* copyright Fett263 FallenOrder (Crystal Chamber) OS7 Style
OS7.12 v1.017-p
Single Style
Base Style: Fallen Order Cal Kestis

Off Behavior: Power Wave Erratic [Color: Match ON Color]

Base Color: BaseColorArg (0)

--Effects Included--
Ignition Effect: Instant [Color: IgnitionColorArg]
Retraction Effect: Instant [Color: RetractionColorArg]



BladeConfig blades[] = {
 { 0, WS281XBladePtr<144, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3> >(),
    WS281XBladePtr<144, blade2Pin, Color8::GRB, PowerPINS<bladePowerPin4, bladePowerPin5> >(), CONFIGARRAY(presets) },

Button PowerButton(BUTTON_POWER, powerButtonPin, "pow");
Button AuxButton(BUTTON_AUX, auxPin, "aux");

 /* Generated with Fett263 Config Helper v3.05 */

I tried that it didn’t do anything when I typed in “effects”. I removed disable diagnostic commands from my config and I have the board connected to Arduino.

1 Like

Did you upload the config with the define removed first?

I should also mention when powering on the saber it lags then says error in font directory but lights and sounds for the blade style seam to work fine. Can’t access edit menu or settings menu at all it just says error in font directory even though I copied and pasted the common folder just like I’ve always done

Remove the screenshot, per the forum rules we don’t use screenshots when you can just copy and paste the results.

It looks like you have an issue in your Voice Pack, I’d recommend trying a different Voice Pack for ‘common’.

Sorry I tried to copy and paste but the txt became jumbled every time I tried and it wouldn’t copy. I’ve tried two different voice packs same issue with both. It’s the same voice pack file I’ve used on every other build and haven’t had an issue until now

Then your SD card may be corrupted. Back up the files, reformat the card and reload the files. Be sure to properly ‘Eject’ the SD from the computer anytime its connected to the computer. If that doesn’t work you may need a new SD.

I’ve honestly already tried all of the above with no luck. I feel like it has to be some sort of file corruption because these are the same sound folders I’ve used countless other times and never had an issue. I’m going to try and reformat the ssd card and add the sound folders on a windows computer and see if that makes a difference. Only thing I can think of is Mac isn’t copying the files properly to the ssd card

You might ask @NoSloppy I think there was an issue a while back with some voice packs but don’t recall solution. He may have insight.

I’d like to see the output of the effects command. Can you cut-n-paste it here? Please make sure to add three backticks (`) on a separate line before the cut-n-paste to keep the formatting. (And then end it with three backticks as well.)

Aldo, do you have a voice pack in “common” ?

So after formatting the SD card again I was able to get a working config with just one preset working without any errors. However now that I am trying to add my full config and presets I am still getting an “error in font directory” directly on boot for my first preset. The first preset does have alt fonts but I have labeled them correctly, they have the same sub folders, same amount of files in each folders, and all file labels match. Here is the result of the “effects” command:

Found clrlst files: 1-27 using 2 digits in subdirs in common
Found mnum files: 1-20 in subdirs in common
Found medit files: one unnumbered file in common
Found vmend files: one unnumbered file in common
Found vmbegin files: one unnumbered file in common
Found lowbatt files: one unnumbered file in subdirs in Cal
Found altchng files: one unnumbered file in Cal
Found ccchange files: one unnumbered file in Cal
Found ccend files: one unnumbered file in Cal
Found ccbegin files: one unnumbered file in Cal
Found color files: one unnumbered file in subdirs in Cal
Found endlb files: 1-3 in subdirs in Cal
Found lb files: one unnumbered file in subdirs in Cal
Found bgnlb files: 1-3 in subdirs in Cal
Found endmelt files: one unnumbered file in subdirs in Cal
Found melt files: one unnumbered file in subdirs in Cal
Found bgnmelt files: one unnumbered file in subdirs in Cal
Found drag files: 1-1 in subdirs in Cal
Found swingh files: 1-4 in subdirs SOME FILES ARE MISSING! 8 != 6 in Cal
Found swingl files: 1-4 in subdirs in Cal
Found swng files: 1-16 in subdirs in Cal
Found lock files: 1-1 in subdirs in Cal
Found out files: 1-4 in subdirs in Cal
Found in files: 1-2 in subdirs in Cal
Found clsh files: 1-16 in subdirs in Cal
Found blst files: 1-8 in subdirs in Cal
Found endlock files: 1-4 in subdirs in Cal
Found font files: one unnumbered file in Cal
Found stab files: 1-4 in subdirs in Cal
Found force files: 1-11 in subdirs in Cal
Found hum files: one unnumbered file in Cal
Found boot files: 1-1 in subdirs in Cal

Edit mode voice pack is working fine now since I formatted the SD card. Ive gone through every file in the “Cal” font folder countless times and I can’t find any issues.

So what is up with your swingh files?
Do you have 4 swingh file in one alt dir and 2 in another or something?

No I actually have 16 swing files in each alt dir. All are numbered swng1-swng16. Other then getting the “error in font directory” on boot and the “Cal” font. All presents and sound fonts seam to be working fine.

swingh not swng

Sorry I was looking at the wrong folder. I have 4 total swingh files in each alt folder. Each labeled swingh1-swingh4. After looking at that folder I realized 2 of them in one folder was missing the period between the file name and wav. Everything is working great now. Thank you so much for your help. I appreciate all you and @Fett263 do! You guys are awesome