"Error in Font Directory"

I’m having some strange errors when adding sound fonts to my proffieboard. For two fonts in particular, when selecting them it will play the “Error in Font Directory” message at the same time as the normal boot sound. I’ve reflashed the board several times but each time the error message continues to play, even though the font behaves normally. Any ideas for how to prevent that message from playing?

I have a Sabertrio Aeryn with Proffieboard v2.2/Firmware V6.7. I’ve attached my config file for clarity. The two fonts in question are “8-UNLIGHTSTABLE” and “9-RONIN”

Thanks in advance for your time and help!
s3config.h (56.4 KB)

It means the font has sounds out of sequence. All sounds need to be sequential 01,02,03,04, not 01,03,04, etc.


Thank you for the reply! I combed through both fonts and corrected one error I found in the Ronin font, however after making sure all the sounds were sequential and re-flashing I still have the same error.

You shouldn’t need to reflash, the error is on the SD in the font, just fix and the error will go away. Double check in all subfolders of the font giving you the error. If you’re hearing it on boot that’s what it means so the OS found something you missed, if you’re unsure you can hook up to Serial Monitor and it should show which sound(s) caused.

1 Like

Thank you, I’ll double check everything again and see if I can find what’s causing the error. I’ll report back once I’ve fixed it. Thanks for your help, I’m a total newbie at this so you being patient with me is much appreciated.

FIXED! I had multiple “lowbatt” files, one in the root and one in a folder. Removing the extraneous file solved the problem and I’ll be on the lookout for that in the future when adding more sound files. Thank you so much for the help!