Dead Board?

New board, but I did not test before installing (I know, I know. Next time for sure). No chimes/beeps when plugging in USB (proven cable) to computer, and the board doesn’t show up on “Devices and printers” nor in Arduino. Does not seem to go into BOOTLOADER with button sequence or hold reset/plug in USB method. Still get “font directory not found” when a battery is installed. Does not show BOOTLOADER in Zadig either.

Arduino shows:
Sketch uses 257968 bytes (98%) of program storage space. Maximum is 262144 bytes.
“Done uploading”

But nothing. Any help is appreciated.

Is this a V2 or V3 board? (If it’s a V3, we can use the status led to help…)
Even though the cable is proven, it might be worth trying a different cable anyways.

Holding reset and plug in USB is wrong. You should hold BOOT and plug in USB.

Boot, that’s what I meant. Apologies.

It’s a V2 board. I’ve tried three different cables, all with no success. Other new V2s I have (not the same batch) work fine.

You could try USB and battery power at the same time.
It’s possible that the board isn’t getting power from USB, but work just fine once it gets power.

Other than that, it’s seems fairly clear it’s not working properly.
Do you have warranty on this board?

I’ll try that then as a last hope.

Possibly. I’ll have to dig up where I got it. Thank you, Professor.