Custom soundfont not playing hum, pstoff, activation, but every other font works?

video explanation

Been having this really weird issue with my saber. Working on a custom ULTRAKILL soundfont, but most of the sounds just won’t play. They’re all WAV files and most of them are in mono (the hum is in mono, I checked) but it refuses to play.

After checking in the serial monitor, my SD speed is about 1000 kb/s (not exact but pretty close) which is about the same as my other sabers, which I don’t have issues with.

Has anyone had this issue before?

Make all the waves 44.1kHz 16bit mono PCM

Will try that, it was set to 48k 32 bit.

It doesn’t seem to be changing anything. I changed the bit rarte and khz in Audacity, but when I save and copy it back in it still says 48k 32 bit. Still doesn’t work on my saber.

Edit: nevermind lol, it’s working

Got it?
Audacity …you need to export as WAV after setting the project rate in the bottom left corner to 44100. Then on the export dialog, choose Microsoft 16bit.

I tried changing the 32bit to 16bit, which didn’t work, but after changing it to 44.2kHz it worked anyway, the whole thing works now. Thanks man