Config won’t upload? And font directory not found

I recently bought a lightsaber with a proffie 2.2 which came with about 25 soundfonts but I wanted to add my own, when I looked for a copy of the config file I found it but there were what I am assuming “unrecognizable characters” (I bought it from alli express and assume part of it wasn’t in English). So I made a new config file by following step by step on a tutorial on YouTube, the only thing that I didn’t do was add a “common file” in the video it looks to be voice command sounds but I added one any way and I am still having the same issue so I eventually took it out (idk if that could be an issue). Back to the problem, after making my config with fett263’s very helpful tool. I added my soundfonts and uploaded the config through arduino and it said done so I put the as card and battery in. When I turned it on I got the “font directory not found” on all of my founts. BUT they weren’t my new founts, I only had about 11 founts that I made along with my config but the fonts that had no audio had the original 25 soundfont’s blade styles. One of the fonts however worked, which is also the only soundfont I used from the original config along with its exact same file name and exact same blade style code as the original. I have no idea what to do, I am very new to this. If someone could help me out I’d really appreciate it, thanks!

You should post your config here.
Do you have #define KEEP_SAVEFILES_WHEN_PROGRAMMING in the config file?

I would just delete any of the save files from the SD and start fresh:
presets.ini, presets.tmp
global.ini, global.tmp
curstate.ini, curstate.tmp

Also, check this out::

First of all the “unrecognized characters” are usually smart quotes, caused by using wordpad or similar on a config file. It’s usually fixable by using a proper text editor, like Notepad++.

Second, post your config file, and specify exactly which presets works and which ones do not, and we’ll see if we can figure it out.

the config file i made: myconfig.txt

The original config i cannot share via link, idk why but it will not let me

The config file looks reasonable, which would mean that the problem is on the SD card in one way or another.

Do you have a “common” directory on your SD card?
If you don’t have one, you would get “font directory not found” for all of the presets.

Does it have an odd name or something?

i do not have a “common” file, in the YT tutorial it looked like it was just voice commands. Should i add one?


no, its weird, i can share it via mail but when i try and chare it via link it says “link couldn’t be created, try agian later”

Create a common folder on the SD card, then download and unzip a voice pack into it. (from here: Free prop sounds)

These files are required to make edit mode work, which you have enabled in your config file. If you don’t want to use edit mode, there are other options as well.

I added it and it did not change anything, i still get the old config blade effects with the only sound being “font directory not found”


Are you sure it’s actually uploading? (Or do you only see a 0-10 count?)

i see a 0-10 count and it says done

Please run proffie-dfu-setup.exe

i downloaded it and followed those steps and got the same result (1-10 done). I forgot to mention I’m doing this by putting the micro SD card in my computer and putting it back in the saber, should i use the micro usb port instead?

Programming the board does not do anything to the SD card at all.
The finished program is stored in memory on the board itself, so yes, you need to connect your computer to the micro-usb port for it to work.

that worked! but i think i have to use zidig, “cannot open DFU divice” appeared after every number 1-10. what should i do now?

proffie-dfu-setup.exe should take care of that.
(It does exactly the same thing tha zadig does.)

You can try using zadig to see if that helps, just make sure to follow the instructions carefully.

If zadig doesn’t help, please check what driver is attached to the “STM32 BOOTLOADER” device. If it is a guillemot driver, then see these isntructions:

oh my god it works thank you so much!!!

the way i adjusted the volume is different and i do not know how? the way i used to do it was hold aux for 2 sec

Instructions for how to use it can be found here: