Computer not recognizing Proffieboard

Hello there. I have two brand new Proffieboards purchased from the same seller. One of the boards is recognized and can be programmed by my computer using ProffieOS as per usual, but the other one is not being recognized. I’m using the same computer, same USB port, and same micro-USB cable, but I’m still not able to work with the second board as expected. My computer makes the “device attached” sound when I plug the second board in and shows it as a USB-connected device, but it will not appear in ProffieOS even after attempting to reset it from the buttons on the board itself. Before I ship it back, does anyone have any clever ideas? Thank you.

You should send it back.
Where did you get it?

@CrueGuyRob Nothing you’ve mentioned here says you tried to program it. Also, your button pressing procedure isn’t clear.
Maybe you should try just manually putting the board in bootloader mode, and upload a known-good config file.
To do that, hold the BOOT button, press and release the RESET button, THEN release BOOT. Hit upload in Arduino regardless of seeing the board under Tootls>Port.

1 Like

I bought it from the Saber Armory and Khal is already working on sending me a replacement. Thank you!

1 Like

Hello again. I’m having a similar issue again, although this time under very different circumstances. Before wiring, I took a brand new ProffieBoard and plugged it into my computer to flash a new config. The computer recognized it, assigned a ProffieBoard number to it, and then the problems started. For some reason, ProffieOS 6.7 running on my computer would not start the verification process when I pressed the button. It also would not attempt to upload the config through the upload button. I reset the computer, deleted and reinstalled ProffieOS multiple times, but could not get ProffieOS to verify or upload. I have since deleted Arduino and reinstalled it which has fixed the problem of not being able to verify the config, but now the board that was connected with I first encountered the problem will not be seen by my computer (other new boards will). I’ve pressed “boot” + “reset” multiple times and have heard the typical connection sounds from my computer, but it still won’t show in my devices and I cannot flash a config to it.

Short version: ProffieOS/Arduino went nutty on my computer and would not do anything when “verify” was pressed, board that was previously showing as connected to computer at the time no longer connects and does not work.

Thanks for any guidance.

Did you do exactly this?

If boards don’t show up as STM32 BOOTLOADER after BOOT+RESET and other sources of errors have been eliminated, such as cables, then the board is almost certainly broken in some way. Windows may still play a chime just because it detects that something is drawing power.

1 Like