Computer can’t recognize Proffie (MAC)

I was flashing a new config to the board and the upload was interrupted, I went and plugged it back in and now the port won’t show up in arduino. I tried the whole BOOT + RESET dance and came up with nothing. I went into the system report to check on the connected devices and the STM32 BOOTLOADER won’t even show up. Is it bricked?

It really shouldn’t be.
Note that when you do BOOT+RESET, you won’t get a port, but you can upload the code anyways. STM32 BOOTLOADER really ought to show up when you hold boot and click reset though. The buttons can sometimes be fiddly, are you sure you’re actually pressing it properly?

I noticed you didn’t say how it got interrupted. I’m assuming it wasn’t struck by lightning or something?

I suspect you may have unknowingly pulled the cable before the progress bar finished. Basically you stopped the upload and this process is how to redo it. *Don’t worry, you’re not the first nor the last to do this, I’ve even accidentally done it.

For Arduino, make sure TOOLS lists the structures out as Fredrik said above. ProffieBoardV2, Serial + Mass Storage +WEBUSB NOTE WEBUSB WILL NOT WORK ON SAFARI BUT DO IT ANYHOW, SDCARD (SPI), 80 Mhz, Smallest Code…

Go ahead and redo the BOOT+RESET. Ignore that the board won’t come up under TOOLS<PORT. Connect your cable, likely there will be no sound recognition after the two button press and release procedure, nor will there be a board recognition sound at this point. You’re forcing the upload. Take a deep breath and TRUST IN THE FORCE.

NOTE: You will want to open up your Arduino screen to full size so you can easily watch how this proceeds to better familiarize yourself with what scripts show as the checks and initializations happen. A lot of times the red script and the initially small window make it appear your upload failed but it’s part of the common checks and initializations Arduino does. It just looks funny on Macs. Your button presses are done and you’ve connected your cable, Arduino is up (the board likely doesn’t show but ignore that). Now simply press the upload button and LET IT BE and WAIT. Watch or scroll down the red script and watch the progress bar proceed,. Unless you see a 10 9 8 7 6… countdown the progress bar should show the upload happening and if your config is properly setup the first preset’s font select sound will play after the progress bar reaches 99%. It’ll sound a little distorted because the board is power off, but it should play. Unplug the board and try it out.

@profezzorn In this case since it’s a common concern with Macs, with your permission I’m happy to take and reply with screen shots for the step by steps if anyone needs the visuals. This topic would be perfect as a “Sticky”… “Where’s My Mac Upload?”

Dunno. I beg to differ on this statement.
It’s generally a breeze compared to Windows, especially as of late.

1 Like

I had this issue and could only solve it by reflashing on a Windows PC using a fresh Zadig install. Everything was fine after.

No it wasn’t, I got up to check something in the other room and when I came back the cable wasn’t in. I’m not sure how exactly it came out.

Maybe the cable is just no good. Have you tried a different cable?

@NoSloppy I absolutely agree w ya there. Way easier overall than with a PC.

I immediately tested the cable with another board and it worked perfectly so I don’t thing that’s it.

You realize the button press isn’t just “both together”, yes?

  • Plug into the Mac via USB with Arduino open.
  • Hold BOOT
  • Press and release RESET
  • Then release BOOT.
  • Then hit upload in Arduino with a known working config file.
    That’s it.

Please try another cable anyways. It’s entirely possible to have cables that only connect properly to some boards. micro-usb is kind of awful that way. However, it sounds like the cable most likely isn’t the problem.

After many, MANY BOOT + RESET then flashing the board rounds it worked. Thanks everyone!

1 Like

We’ve all been there, once after three tries I walked away, called a buddy up, then while talking got it to flash. Obviously the Force was with ya. :smile: Next time you see someone in the same boat chime in and share the trick.

hate macs, pc is a pain, SO I WENT LINUX. currently daily driving a manjaro linux distro on a latitude e6510 (released 2008) install was literally 3 steps, took me seconds to get the board recognised.

I’ve been using Linux since 1991, and while it’s THE BEST, it’s also not for everyone.
Linux tends to run just fine on older hardware though, so it can be a great way to make an old laptop/desktop usable again.