Compilation Error Message

In file included from /Users/Scottie/Desktop/ProffieOS/config/mysaber_config.h:34,
from /Users/Scottie/Desktop/ProffieOS/ProffieOS.ino:565:
/Users/Scottie/Desktop/ProffieOS/props/saber_fett263_buttons.h:539:2: error: #error /props/saber_fett263_buttons.h requires 1, 2 or 3 Buttons for operation
539 | #error /props/saber_fett263_buttons.h requires 1, 2 or 3 Buttons for operation
| ^~~~~

exit status 1

Compilation error: #error /props/saber_fett263_buttons.h requires 1, 2 or 3 Buttons for operation.

Not really sure why I keep getting this error. I am new to this any help is greatly appreciated!

Post your config, best guess is you don’t have any buttons defined, my prop requires 1, 2 or 3 buttons as the error says.

mysaber_config.h (131.3 KB)

This is my config any help is greatly appreciated!

You have a typo:

#define NUM_BUTTONS 2
Iconst unsigned int maxLedsPerStrip = 144;

Delete the I before const. Probably messing the line before.

Thanks for the response! I just tried it and am still getting the same error.

I don’t think you’re uploading the config you think you are, that config would have a very different error message. You should close Arduino, navigate to the ProffieOS folder where extracted it and then double-click the ProffieOS.ino file to launch. Double check your #define CONFIG_FILE is actually the file you want and that it is in the /config folder of ProffieOS.

Thanks for the response. I just retried that as well. Should I re-download the ProffieOS folder. I triple checked that the #define CONFIG_FILE is the file I wanted. I renamed the config file to just "mysaber’ in the ProffieOS config folder to be sure but still no dice. It is the only file I have with that name on my computer right now.

If you renamed the config and still get an error post the config and the full error message (use and share the URL as it’s easier for us to see without having to download files).

This is the pastebin URL. I put the error message as the first comment Mysaber

That config produces a bunch of errors but not the error you’re showing, so you’re still trying to upload a different config than the one you’re sharing and the one you’re sharing is missing some required defines like VOLUME, etc. I would reach out to @Sabertrio_Support to get a config that works and then make sure you’re uploading the config you think you are.

I am not sure how that code got all jacked up. I guess thats the nature of the beast. So I restarted everything from scratch the middle part with the sound fonts were the same. I just restarted the top part and made sure the DEFINES were correct. I also was sure to only open Arduino from the new proffieOS that I downloaded and made sure to only work from that config file. The code I had before is gone but now I am getting an error about display sound volume. I am uploading the pastebin now my config new. I feel like i’m getting warmer.

If it helps I am following these instructionsProffieBoard setup

Yeah, you can’t use the styles from SaberTrio in the main OS, they made them incompatible. You will need to regenerate in my library, the links in the copyright section will guide you to correct base style, then the lusted options will help you recreate.

You can also try this tool, it will walk you through setting up your config correctly.

If I am reading this right you are saying I need to change the blade styles on my SD card from all of the Sabertrio to make them compatible with Arduino or regenerate them in my library if I want the same ones?

The styles that SaberTrio provided in your config will not work with the main OS. You can reach out to them for an updated config - or- you can regenerate the styles in my Style Library to do it yourself. The styles in your config will not compile.

The config on your SD card is a backup copy, when you’re making edits you’re saving to the /config folder inside ProffieOS on your computer, correct?
You can’t upload the config from the SD, it needs to reside in the ProffieOS/config folder for Arduino to compile & upload. This may be part of the problem you’re experiencing.
You may want to use this page and read through everything to familiarize yourself with updating your Proffieboard.

Yes I am uploading from from inside the Proffie OS. I appreciate your help. I getting the hang of it all more and more. Thanks for the sources. Ill read up on everything

Hey Scottie. Just saw this thread and just wanted to chime in with some additional details! From what we see of your config, it seems like the config file you were using as your base was from our 3.01 preconfig which, as Fett explained, was incompatible with the main OS.

The release of our 3.02 preconfig makes it so that the saber is compatible with Fett’s prop files. You can download the update from our support page under the Proffie Firmware section. Hope this helps!

@Sabertrio_Support We cannot open the download zip without a password. DM me via FB.

@Revo Replied to you! We password-protected the files due to the distribution rights of the included sound fonts. If anyone is looking to get the config files without the sound fonts, just drop us a message. :slight_smile: