CDC (Code 10)

I uploaded a soundfont into my proffieboard for the first time yesterday and it all worked out. Today, i tried to do it again and ran into a driver issue. Under “ports” in device manager, the CDC data (interface 2)(com4) has a code 10 (this device cannot start). I’m worried that i broke the hardware or that something is corrupted.

I have tried restarting the computer, uninstalling and reinstalling drivers, and everything i can think of. I would love some insight on this.

The serial (interface 0)(com3) is working like it should.

This may be normal. There is a CDC data interface for WebUSB that doesn’t have a driver, maybe that is what is happening here?

So i might have the wrong cdc data? Or the wrong driver for cdc data?

I think everything is fine, but I’ll have to boot up windows to compare.
If you have some weird driver thing going on, it sounds like it is only affecting the WebUSB interface. It’s also possible that the device manager is just confused because there is no driver for that interface, which is normal.

Thank you, this problem exceeds my knowledge of the subject, so i’m not even sure what I’m looking for or where to look for it at this point

So is there something that doesn’t actually work? You can still program the board right?
Does the ProffieOS workbench work? (Do you use it? Do you care?)
If everything is working, I would just ignore the error in the device manager.

The last time i did the final upload, i thought everything was fine, but when i went to eject the device, it said it was still in use and that i shouldnt disconnect it. So i went in to device manager and saw the code 10

I just did the final upload and ejected the device. I dont know whats different this time, but it works. thank you master