Can't figure out Volume menu and battery percentage

Hey everyone. Switched over to the new prop and got most things working great including party mode (thank you so cool!) but I can’t figure out how to change my volume/enter volume menu and get my battery percentage to work. Using thw button commands does nothing for both. Don’t know how to define EFFECT_BATTERY_LEVEL but already have the other define in there. I hope this pastebin post is correct first time using it. Forgive me for these questions, new to proffie. Any help appreciated.


Controls listed here, make sure you did the required set up per Set Up Instructions.

If you want a visual battery effect your style(s) needs to include, see my library for options in the Enhancements screen.

Think I figured it out. Voice files were in wrong place. Though it was odd, there is another common folder in my commonb folder, but if I move it all to root common folder, I get a directory error. I had to copy battery and volume speciifc files to root and it worked. I know that’s not ideal and a bit of a mess but it works Any suggetsions are welcome for cleaning this up.

Thanks everyone!

My prop requires “common” in the root per the Set Up Instructions and it can only be named “common”.

Totally understand. But the odd thing is, orignally I had a common folder in the root common folder, so, commom/common and it was working with everything else, except for the voice pack. I then took everyhting out of common/common and put it into root common, and got a directory error message switching fonts. Then I just copied volume and battery related wavs to root folder and those functions worked. I know this is a bandaid workaround, but not sure why I get the error if I move everything out of common/common. If you check my pastbin I think I have the presets set up correctly.

The Voice Prompt sounds belong in either the root of the font or “common” in the root of the SD, if you add subfolders things will not work properly, that’s why I documented the required Set Up.

Right. Appreciate all of your guidance. It was a weird carryover from an old config that worked until I switched to the fett prop. Haven’t tried Edit mode yet but I’ll see what happens. Thank you so much for all of your hard work. Love these features.