Cannot Connect Proffieboard to my Computer anymore

Hello, I’ve recently had issues connecting my proffieboard V2 to my computer.
After setting it up at home and a little help from this forum, I figured out how to add new fonts and bladestyles to my saber. Everything has been working perfectly. My problems recently have occurred when I used a different cable and it didn’t make sound like it usually does when connected to my pc. I’ve tried later testing connection with the cable that has worked before and it receives power but the computer only detects it when it is in bootloader mode. I’m not sure if its normal but the board also gets decently hot just being connected to my pc.

Also, I can’t find the rules for this forum, so if I unknowingly broke a rule, I’m sorry it wasn’t on purpose.

I’ll add that using its flashed configuration everything works normally, it just has problems connecting to my pc.

So what is it that doesn’t work?
The serial port?
The drive?
Something else?

The rules can be found here;
(You have not broken any rules so far…)

My sd card is working fine. The port doesn’t show up on the computer, it just detects the bootloader when I press the buttons down. I’m not sure if I damaged the board, or if its something in windows. If I had to guess the problem was caused because I connected a different cable that wasn’t meant for what I was using it for.

Is there a possibility that you ran zadig on the proffieboard device instead of on the STM32 BOOTLOADER device?

This page has more information, and the video at the bottom shows how to fix it if that is the problem:

Oh, and if you can still access the board in bootloader mode, then it is unlikely that anything on the board is damaged. This sounds more like a software/driver issue.

I followed your tutorial youtube video, and have realized I used zadig on the proffieboard not the bootloader. However in the video you show how to uninstall those drivers from device manager, my problem is that I don’t see the ‘serial’ device in USB devices, and it doesn’t show up in devices and printers.

Things may have changed a bit since I made that video, but there should still be some way to find the device. (While the proffieboard is plugged in and NOT in bootloader mode.)

Try the device manager?

OK, now its in a loop of getting detected in windows and disconnecting. It shows up now, but not long enough to change anything. I assume I need a different cable, as its not having a stable connection. I’ll get back once I get a stable connection to my pc.

It’s also possible that the cable is fine, but that something else goes wrong.
For instance, this can happen if you have a bad programming on your board, or if the SD card is corrupt.
It also seems to happen when you have mass storage on, but no sd card in the board.

OK, seems to be working now. Thanks for your time and help so I could get it back running. I’ve reformatted my SD card and have others I can use if that’s ever a problem. Cheers.