Can a faulty SD Card Pop the Amp?

Board 1

Vid here: https://1drv.ms/v/s!AiDpCqU72ykghNdrnSZRnW7BEPkv5w?e=GKJwON

Issues … sounds played from the SD card are garbage. With SD card removed, board warnings play fine

Standard stable 4.7 flash & standard font pack that I always use.

Have tried

  • new speaker
  • board reflash
  • board reformat & new files
  • new SD card
  • Board voltage is fine

This file is a standard Teensy Soundfont bootup. Instead of tenths of a sec… it just drraaaaggggggssss out.

Board 2

I replaced the board. Same issue. Only common parts were SD Card, speaker (tested 8 ohm), RCP (RCP tested OK).

Serial monitor:
4.09 with battery connected
2.03 on USB only, settling to 1.98v

I’ve noted a test of the 5V pin is prudent. I’m only getting 0.87v on the 5v pin with the cell hooked up. 0.96v on the 5v pin just on USB.

Serial Monitor: https://1drv.ms/u/s!AiDpCqU72ykghNdzKaT4IYR54nVUnQ?e=p7W775

Result of “SDTest” on Serial Monitor: https://1drv.ms/t/s!AiDpCqU72ykghNd1C7PAITe6TaeGSA?e=6m2Plp

Please try a newer version of ProffieOS.

Thanks for the swift reply, Fred. I will tomorrow (later here now), but note this is a stable ‘goto’ build I’ve used on scores of prior installs. Would the boards specs have changed in later runs causing issue with earlier FW builds? Pretty sure I’ve successfully used boards from the same batch with this 4.7 build.

The only hardware change I’m aware of that requires an updated code change is the motion chip on some boards distributed by LGT/Darkwolf.
I’m do not see how this would affect your audio issue directly, but it does answer your question.
It won’t hurt to try this replacement ProffieOS/motion/lsm6ds3h.h file

Thanks for the info @NoSloppy . They are both KR boards.

ProffieOS 4.7 has a bug which only shows up with version 2.x of the Arduino-Proffieboard plugin. If you want to use ProffieOS 4.x, either upgrade to 4.9 or downgrade your Arduino-Proffieboard plugin to 1.x

3 Likes

^That^

I had the same issue when I went to use 4.7 and the V2 board I had when I was fine on the original boards. The second I moved to 5… it went away.

**On that note, as well as the other issue, thanks again for the solutions Fredrik!

1 Like

Thanks for the info. I’ve just flashed a 5.7 build I’d earlier prepped and I now have a fault free boot. On another note, the reason I rolled back from the 5.7 build to the 4.7 build is that I couldn’t get the colour wheel on a single switch config to activate. I couldn’t get an answer on DS’s FB Proffieboard Support Group, so opted for the rollback (I’ve only just found ‘The Crucible’). Config was fault free. Is this a bug that has been fixed up in 5.9?

Thanks again for the above info.

  • A single switch RGB config.

Entering colorchange mode is just a matter of doing the right button action assigned by whichever prop file you’re using.
The top comments section of each prop has a how-to.
Which are you using?

Yeah … it was a weird one. RGB setup using the standard prop file and on a single switch config, colour wheel is activated by holding PWR + twist gesture. Have done it a million times but it wouldn’t kick in on 5.7. Rolled back to my old 4.7 config and it activated fine.

We can figure out the color wheel problem.
Post your config file and we’ll take a look.

Thanks Fredrik. Config is a straight cut n paste from Proffieboard V2 with only the Volume and the clash threshold changed. I’ve just re-flashed a single button RGB setup with 5.9. Same result. No colour wheel on PWR (hold) + TWIST.


#ifdef CONFIG_TOP
#include "proffieboard_v2_config.h"
#define NUM_BLADES 1
#define NUM_BUTTONS 1
#define VOLUME 1500
const unsigned int maxLedsPerStrip = 144;
#define CLASH_THRESHOLD_G 3.0
#define ENABLE_AUDIO
#define ENABLE_MOTION
#define ENABLE_WS2811
#define ENABLE_SD
#endif

#ifdef CONFIG_PRESETS
Preset presets[] = {
   { "TeensySF", "tracks/venus.wav",
    StyleNormalPtr<CYAN, WHITE, 300, 800>(), "cyan"},
   { "SmthJedi", "tracks/mars.wav",
    StylePtr<InOutSparkTip<EASYBLADE(BLUE, WHITE), 300, 800> >(), "blue"},
   { "SmthGrey", "tracks/mercury.wav",
    StyleNormalPtr<RED, WHITE, 300, 800>(), "red"},
   { "SmthFuzz", "tracks/uranus.wav",
    StylePtr<InOutHelper<EASYBLADE(OnSpark<GREEN>, WHITE), 300, 800> >(), "green"},
   { "RgueCmdr", "tracks/venus.wav",
    StyleNormalPtr<WHITE, RED, 300, 800, RED>(), "white"},
   { "TthCrstl", "tracks/mars.wav",
    StyleNormalPtr<AudioFlicker<YELLOW, WHITE>, BLUE, 300, 800>(), "yellow"},
   { "TeensySF", "tracks/mercury.wav",
    StylePtr<InOutSparkTip<EASYBLADE(MAGENTA, WHITE), 300, 800> >(), "magenta"},
   { "SmthJedi", "tracks/uranus.wav",
    StyleStrobePtr<WHITE, Rainbow, 15, 300, 800>(), "strobe"}
};
BladeConfig blades[] = {
 { 0, SimpleBladePtr<CreeXPE2RedTemplate<1000>, CreeXPE2GreenTemplate<0>, CreeXPE2BlueTemplate<240>, NoLED, bladePowerPin1, bladePowerPin2, bladePowerPin3, -1>(), CONFIGARRAY(presets) },
};
#endif

#ifdef CONFIG_BUTTONS
Button PowerButton(BUTTON_POWER, powerButtonPin, "pow");
#endif