Cal Kestis V3 Fallen Saber from 89Sabers - Anyone Purchase and know the pre-loaded config?

I recently got the 89Sabers Cal Kestis V3. I backed up the sdcard when I got it, so I have it intact, but I changed config files. I’d like to put it back to the original settings, but I’m not sure what they were out of the box. It has 3 config files, but they’re all .txt. I thought the config files were .h?
Does anyone know what the out of the box settings are for this saber from 89sabers? …or how I can determine what they were?
The store I bought it from told me to use the 89Sabers config.txt file, but I get an error in Proffie OS when I try that. no directory/file found.

If the contents of the file look right, then it’s probably just a matter of renaming the file from .txt to .h. Note that you might need to turn off the “hide extension” setting in windows to do that.

Alternatively, just create a new, empty .h and paste the contents of the txt file into it.

1 Like


If you’re gonna be playing with code and you don’t already have SublimeText* go download it.

*I suggest this because too many times I see people doing what I did in the beginning and allowing the .txt files to be ran by a program not designed to handle C++ and you end up with non C++ characters that mess things up.

Just in case you need it here’s their current configs.

1 Like

Epic. That’s what I did, but didn’t know if I was supposed to. Thank you!
The 89sabers config.h doesn’t work because it references the proffieboard_config.h, whereas the other two reference proffieboard_v2_config.h. Is that also something I can just change without creating any undesired ripple effects?

Awesome! Appreciate ya!

proffieboard_config.h does work.
It’s just a file that checks which option was selected in Arduino → Boards and then includes proffieboard_v1_config.h or proffieboard_v2_config.h.
But you can also change it.

Honestly, just title the 89 config as something like …


… and then paste that config into the ProffieOS folder’s config folder.

Then goto the ProffieOS.ino in the same ProffieOS folder, open it and down where you see the example config list change whatever is active and missing the 2 // to having them and paste this in the same area.

#define CONFIG_FILE "config/my89sabersconfig.h"

Then while still in Arduino hit FILE and SAVE.
From there hit the [Checkmark] and make sure it all compiles.

If it does and you have your base defines good to go you can then flash the board to see if it corrected things. If you wanna change things from here then just use SublimeText to copy your base backup config file and edit a separate one you’re free to call whateveryouwant.h and paste them into the config folder and put the define in the ProffieOS.ino Arduino.

This way if you ever mess up again you have your base file setup as a backup.

*BTW, welcome to The Crucible and MTFBWY.

1 Like

so the 89sabers config.txt that i changed to .h references proffieboard_confg.h which is not in the config folder. i changed that to proffieboard_v2_config.h, which is in there and now I am getting the following error:
ProffieOS/common/common.h:9:24: error: missing binary operator before token “(”
#if __has_cpp_attribute(no_unique_address)

Either you have the wrong board selected in Arduino->Tools->Board, or you need to update your arduino-proffieboard plugin.

1 Like

i installed 2.2 and stopped getting that warning. thanks! BUT…all the uploads fail, which i haven’t encountered before. terribly sorry, i don’t mean to be high maintenance. i have another saber and with your help and others was able to create my own styles and revert back to factory settings. this new saber is giving me fits. this is the result of the upload:

/Users/rorykagan/Library/Arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld: warning: changing start of section .bss by 16 bytes
Sketch uses 221640 bytes (90%) of program storage space. Maximum is 245760 bytes.

thank you! i did all this. file saved, clicked check and compile was fine, but every attempt at upload fails. the result is in my reply to fredrick below. :0/

This means the computer can’t find the board to upload.
Did you run Zadig once when the board was manually in bootloader mode?
That’s part of the setup.
If yes, either you:

  • didn’t select the board under Arduino meny Tools>Board>Proffieboard
  • have a driver conflict
  • your USB cable is possibly bad.

Did you select the Proffiboard port in Arduino → Tools → Port?

i’m on a mac, so zadig wasn’t a part of my installs. because of your USB comment, I disconnected it and then reconnected it and believe it or not, that did the trick!! I think that arduino didn’t like that i had it connected when i restarted my computer. thank you all for your help! really floored with how kind and patient you all are. very, very grateful. MTFBWY!!

1 Like

Right on! and no problem. Pass on what you learn the next time someone needs an assist.

Oh thank the Maker, yes no Zadig for you.
Glad you got it working. Enjoy!

1 Like