!Buttons and controls not working after updates!


This is my first post so I apologise if it has already been mentioned.

I recently bought a v2.2 one button Dark Wolf Proffie core from Padawn Outpost. I went to update the software to 7.2 which was when all of the problems started. I followed the instructions regarding Zadig and Arduino which worked. I then created a config file and transferred the fonts/codes from the original config that were on the SD Card that came with the v2.2. I have made sure that it all relates to a one button and not two and all spelling matches to the font folders.

Since then, I have had issues. The lightsaber lights up with the first font (Kylo Ren) with motion, but then I cannot use the button which lights up. The blade activates and deactivates with gesture controls only.

I’ve tried taking it back to the 6.5 software, but I am still having issues.

Has anyone got any tips on how to solve this issue?

Post your original config and your new config and we’ll take a look.

Did you use the original config to update or did you make your own, you may not have set your CONFIG_BUTTONS correctly? First thing I would do is compare the CONFIG_BUTTONS on the config from the installer to the one you uploaded, if they are different use the one provided by your installer.

If they match, then hook up to the computer, go to Arduino > Tools > Serial Monitor and press a button and see what prints out, if you’re not seeing a button press you may have a wiring issue or bad button.

You can also type “version” if in OS7 to see which prop is enabled and review the controls.