Button leds not turning off?

hello friends. I have a Yoda saber that the seller sent the wrong config for. has been silent for requests for the correct one. I fiddled with some other configs and was able to get everything working perfectly except the accent leds on the buttons. before I reflashed the board, they would turn off a few seconds after turning off the blade. now, they stay on indefinitely. can someone tell me how to enter the define to get them to turn off automatically again? battery drain is going to be awful like this. thank you!

Start by posting the config you’re using.
Also, do you know pin(s) the accent LEDs are wired to?

here is the config. Unfortunately, I don’t know which pins they are wired to. would you be able to tell if I sent a photo of the board?

Your saber is set-up like it has two blades, which seems unlikely for a yoda saber. (two blades with 90 leds each)

Is there a reason for that?

Sort of. We’d be able to see what pads have something soldered to them, but not where those wires actually go to. However, since we already know what works and what doesn’t we should be able to make some educated guesses.

no reason other than that I am still trying to figure out what I am doing here, haha.

aside from the buttons remaining lit, everything else appears to be working perfectly.

Well, in this picture, we can see exactly which pads are used, lockwise:

  • SPKR+
  • SPKR-
  • AUX
  • LED1/2
  • POW
  • BATT-
  • BATT+
  • 5V
  • Data1

For one thing, that means that the second blade in your config, which is operating Data2 and LED4/5 isn’t doing anything and can be removed.

I’m guessing that the switch LED is hooked up to the 5V pad, which means that it would stay on whenever the booster 5V booster is on. The 5V booster stays on kind of a lot, but should turn off when no blades are active and no sounds are playing.

One partcularly common source to having the booster stay on is using blade styles which ProffieOS is unable detect when they are truly off. You could temporarily try a simpler blade style and see if that fixes the problem or not. Also, you could use IDLE_OFF_TIME to have the blades forcibly turned off after a while, which might also fix the problem.

Would I just add the idle time off with a hash tag? Does it need to be in a particular place? Or do I need to add it to each individual blade style?

Thanks again for your help and ridiculously quick replies. Can’t tell you have much it’s appreciated by the whole community.

Or search this forum for examples.

There it is! I need to spend more time with that, obviously. Thank you!

so, I tried inserting #define IDLE_OFF_TIME 60 * 1 * 1000 so it would turn off after one minute, but that didn’t appear to do anything. any thoughts?

What does your config look like now?

If you run the command booster off in the serial monitor, does the LED turn off?
(Or at least blink?)

After turning the saber on and then off, do you see “Booster OFF” in the serial moniitor after a little bit?

If you remove DISABLE_DIAGNOSTIC_COMMANDS from your config file and upload. Then use the whatison command, what do you see? (Note, you may have to temporarily remove some presets to make the upload fit with without DISABLE_DIAGNOSTIC_COMMANDS.)

thanks so much guys, but I’m embarrassed to say that this is now officially way over my head :laughing:. I understand very little of that message. I don’t even know what it means to run the command booster off. also don’t know what the serial monitor is. at this point, until I educate myself a little further, I think my best bet on that one is just to remove the battery when not in use. I guess that’s the recommendation anyways. I also just feel bad having you explain things to me that you probably already have posted somewhere :laughing::man_facepalming:.

I see. thanks. I might put the Yoda on the back burner. I just received my first V3 and trying to figure that one out. thanks again.

here’s my config now. gong to try the serial monitor next.

good news. I uploaded the config with a newer OS, and the buttons are functioning normally now. thanks for your help!