Both buttons stopped working after uploading config file

Good evening everyone.

I’ve found this topic a few times, yet to be answered…

I got myself a used Artsabers Luke Proffie V2.2 saber and wanted to add fonts to it so I followed tutorials by fett and absolute sabers.

I customised the config file to my liking and uploaded it to the board.

It turns on with gesture control, the font and the blade-style work, however, both buttons won’t do anything anymore. They worked perfectly fine before.

I am not able to check for the buttons as the chassis isn’t connected to the buttons when plugged in.

julian_config.h (26.0 KB)

I’ve added the config I’ve made in hope that someone may be able to help me…

Hope you’ll have a wonderful day.

First, it would be weird for your buttons to stop working just because you uploaded a config where the only change is a different set of presets.

Do the buttons work ok if you upload the original config again?

You can test the button actions with the chassis disconnected from them in a couple of ways.

  1. physical test. You can simply short the button pads to ground with a paperclip/jumper wire/tweezers etc… That’s the same as pressing the actual button.
  2. You can use Serial Monitor to send button commands. See here:
    ProffieOS Documentation: Button Commands


So I’ve tried to disable “Thurst on” and such things as they may have caused problems for people in other threads and I am able to light it up and change soundfonts with it now once I press the chassis in really tight.

Now however, whenever I hit the hilt to get a “flash on clash”, it locks up. And when the AUX Button is being pressed it sometimes gives me blaster deflection or a different, somewhat random sound.

Thank you for your reply, NoSloppy!

So the buttons work?

Sounds like you just need to review the controls that the prop file provides.