Bootloader mode not working

When I was using Zadig (yes I know its outdated but I didn’t know that then) the only way to get the board to communicate with the PC was to reinstall two drivers, one for the serial device and one for a ‘hidden’ parent device. Once I did that, it worked fine for a bit but now makes no sound when plugged in, bootloader mode does not work and I’m getting absolutely no signs of live. Not even the PC port detects anything.

This may be bad, or it could just be a bad cable.
Is the saber/board generally working otherwise?
Were you doing anything when it stopped working, or is it more like it stopped working while the saber was sitting on a shelf?

It stopped working while it was stored, so I don’t know exactly when it stopped. The board was making a sound when plugged in before that, and now nothing is happening. I have switched cables and know that is not the source of the problem.

There is no sign of life at all from the board. I think it may be a good idea to contact the seller as it seemed far harder to even get talking with the arduino software.

Have you tried charging the battery?