Bad v2 board?

I wired up a v2 board yesterday and flashed it with a similar config I have on a similar saber. However, the board is booting up slow. The boot sound is slow and distorted. I cleaned the board with isopropyl to make sure i had no residual flux and even desoldered all the wires except power and battery negative with the speaker and no change. Checked with a magnifying glass and cant seem to find any shorts or anything that might cause it. Im thinking the board is defective. Any other ideas on what might cause it?

Try a different SD card to see if that helps.
It could also be a problem with the clock circuit, which can be caused by anything touching the crystal or the two capacitors next to it.

I tried that. Swapped sd cards from my working saber, same thing. I also cleaned the area where the clock circuit just to be safe. No change.

I don’t suppose you picked something other than 80Mhz for the clock speed?

Its set to 80. I noticed that with no sd card the error playback sounds normal. Ive desoldered everything so i can give it another cleaning and check for anything amiss. I ordered some replacement boards in case the board is indeed bad.

Board must be bad. After a thorough cleaning and inspection and rewire, still running slow. Was hoping to salvsge it but no big deal.

Are you certain there’s no bottleneck on the power side of things? I’ve had slow-motion boards before when I’ve just twisted battery wires together to test, but the problem has gone away once those wires were soldered.

I’ve also had boards boot slowly. In one case, I cleaned and cleaned and cleaned everything around the Data1/3.3volt/Gnd pads (which I think is where the clock components the prof mentioned are located) but still the problem persisted, until bizarrely cleaning it yet again suddenly solved it. Use a wooden toothpick with isopropyl to really get in between the components.

I’ve even had problems with hot glue that’s spread between positive and negative connections on neo connectors or accent strips cause problems. Of course hot glue isn’t conductive, so that’s impossible, right? Well all I can tell you is that once I removed it everything started working right.

But in all the installs I’ve done (160+), I’ve actually only had two instances where it turned out to be the board that was bad and had to be replaced, and both of those were to do with USB connection issues.

As such, I would absolutely eliminate absolutely everything else absolutely possible before concluding the board itself is the culprit.

Hope that helps. :slight_smile:

Shouldn’t it be 800 MHz, not 80?

No, 800MHz is nearly a GHz, the STM32L4 does not run that fast.

1 Like

Ah OK. Thanks ryry. I think I’m getting my megahertz and kilohertz confused. LOL! :sweat_smile:

I scrubbed and scrubbed with an old toothbrush and it looked pretty clean. After rewiring it, also scrubbed. At this point i’ve only wired in battery+/- and sound to eliminate anything else. Also rewired the battery contacts. Power off the battery + isnt all that twisted and is a short run directly to a kill switch.

1 Like

Havent quiet figured out the root cause yet. Swapped out the board and uploaded and had the same problem. Then i removed all the blade presets and left one of them (totally different default blade/font) upgraded to latest and no more problem. I may have a corrupt font (although a working sd card with the same starting font had the same problem) or something in my blade presets related to the font (boot or music).

Does the problem change or go away if you use the experimental version of the arduino-proffieboard plugin?