Bad board / battery?

I recently bought my first Proffie saber - Ultimate Works Hero V1 from The Pach Store. After watching a million YouTube videos, I successfully flashed the board with 6.7 and uploaded some fonts. I went slow. Changed a thing or two, verified and uploaded in Arduino, tested on the saber. Then, randomly, the board stopped showing up under Port. I tried the button trick to enter bootloader mode. Nothing. The board has stopped talking / responding in any way. I thought maybe the battery was dead so I fully charged it and tried again. Nothing. Frustrated, I left it alone for a few days. Then I popped the battery back in and it started doing this (see link below). Sometimes it also says SD card not found before the clicking sound. Saber won’t turn on if I put the core in.

Please help @profezzorn. The Pach Store said they can’t help me until you diagnose the board. I think the board / battery might be bad. The board did get scorching hot when plugged into my Mac for Arduino. This is the cable I’m using. I just got it for this board. It worked for several transfers.

Generally, the board becoming hot is bad. Do you know what part of the board got hot?
“font directory not found” is not unusual in itself, but the little click/chirps that happen afterwards are new to me.
The battery shouldn’t be needed to make the board show up in arduino, so any battery problems shouldn’t really matter when the cable is attached.
The cable you bought should work, but it wouldn’t hurt to try a different cable if you have one available.

So when you entered bootloader mode, you said nothing happened, but how did you actually check? The board will not show up in Arduino->Ports when in bootloader mode. Instead, please read this page to see how you check if the board is detected in bootloader mode:

I’m not sure which part of the board was hot because The Pach Store puts it under plastic. I’m aware font directory not found and SD card not found are normal. It used to say that and I got it working just fine. I know the battery isn’t needed when connected to the computer. In fact, due to the design, it’s impossible to plug the board into the computer while the battery is in the chassis (this is probably by design).

I actually bought 7 cables from 3 different manufactures and they all acted the same. It’s not the cable. Unless all 7 are bad (unlikely). I don’t remember exactly what I did with bootloader mode. When I had success is when it was showing up in Port. I may be able to make changes via bootloader but it doesn’t matter because the saber won’t turn on.

Do you think the board is defective? That’s my gut reaction but they said they won’t replace it unless “If he (you) assessed that the board is faulty, we can go ahead and send it back to be enrolled under warranty program.”

When I touch the plastic covering the board the whole area is blazing hot.

The board got so hot it looks like the SD card is warped and I can’t get it out. They need to replace this.

I would agree. A hot board is caused by a short somewhere. Either inside a chip, or outside of a chip. Either way it’s not something you should have to deal with if you didn’t wire up the board yourself.

The sound is slow, so there’s that…indicating a short.

The Pach Store said they will fix it up they want me to pay for shipping (which is like $60) and it’ll take up to 2 months. Is this something I might be able to fix myself? I can do some basic soldering…

^That. It won’t play the sound at the correct speed/tone, it’s likely shorted and cooked. Send it back.