Assistance needed with "Cannot open DFU device" issue in Arduino

Hey, guys!
So I’m running into a problem now with Arduino IDE (v2.3.2) when trying to upload a new config to my saber.

  • The saber is connected via Rankie Micro USB Cable.
  • The battery has been removed.
  • The SD Card has also been removed.

I created a new config this morning with some new bladestyle codes, downloaded the config (from Fett263’s Config Helper site), replaced the old config with the NEWLY created/downloaded one (as it shares the exact same name).
I verified it first, to make sure that everything was good and that there was no errors. Then when I try to upload the config to my saber, I get the Windows 11 disconnection sound and then this screen shows up.

Cannot open DFU device (Arduino Screenshot)

I’d done a PC restart, too. And that didn’t make any difference. I’m not using Zadig… But I have got the drivers installed obviously. And I also have the Proffieboard Add-on installed in the Boards Manager.
I was able to upload my last config with no issues or problems. That was my first new config that I’d done since getting my saber but now I’m running into this issue, since creating my new config, this morning.

Can anybody help? This is driving me nuts! lol

Thanks!

Basically… What I’m getting inside the bottom panel of the Arduino window, is this;

c:/users/damian/appdata/local/arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: warning: changing start of section .bss by 8 bytes*
Sketch uses 235096 bytes (89%) of program storage space. Maximum is 262144 bytes.
Cannot open DFU device 0483:df11
1
Cannot open DFU device 0483:df11
2
Cannot open DFU device 0483:df11
3
Cannot open DFU device 0483:df11
4
Cannot open DFU device 0483:df11
5
Cannot open DFU device 0483:df11
6
Cannot open DFU device 0483:df11
7
8
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
9
10
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11

If that’s any indicator…

This message almost always means that there is something wrong with the DFU driver. You can try and re-run proffie-dfu-setup.exe and see if that helps.

If that doesn’t help, then there is most likely some other software that has installed a driver for the same USB ID. There are some joystick/racing wheel and 3d printers that apparently do this.

Okay. Thanks!

I’ll try and run the setup file for it again. See if that solves it. Fingers crossed that it does. But all I did, was literally disconnect my gamepad (XBOX One Controller for Windows) and plug-in my saber via the data cable.

What I don’t understand, is how it’s now doing this… Whereas when I was able to upload my config the first time around, I didn’t have this issue and it did it successfully.

So, I THINK I’ve fixed the issue. Maybe you can confirm that all is now functioning normally as it should be.

I re-downloaded the proffie-dfu-setup.exe file and re-installed the drivers/software from that package. No issues.

I then went into Arduino, clicked on “File” > “Preferences” and removed the Additional boards manager URLs line and clicked on OK. I then went back to that line and re-added a fresh copy of what needs to be there. Clicked on OK.
Next, onto the Boards Manager and I uninstalled the “Proffieboard” Add-on. Then re-installed it (3.6).

I then made sure that in my “Tools” menu, that the settings matched what they should be set as. I did notice however, that my USB Type option was set to “Serial” (ONLY), where as it should be:
“Serial + Mass Storage + WebUSB”. So I don’t know whether that has anything to do with it or not.

Anyhow, I ran the Upload to the saber again and this time, IT WORKED!! (I think)

"Opening DFU capable USB device…
ID 0483:df11
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 2048
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08000000, size = 239104

Download [ ] 0% 0 bytes
Download [ ] 1% 4096 bytes
Download [ ] 3% 8192 bytes
Download [= ] 4% 10240 bytes
Download [= ] 5% 14336 bytes

to the bottom;

Download [======================== ] 98% 235520 bytes
Download [=========================] 100% 239104 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

I then disconnected my saber from the PC, after that.

So for anybody else having this issue or comes across this issue in the future… Those are the steps I took to fix (I think) it.

Unless something very weird is going on, only the proffie-dfu-setup.exe will have any effect on this particular error. The other things you did should not make a difference.

But hey, weird stuff does happen… :slight_smile:

1 Like

Serial only is a fine choice. You only “need” the other 2 options added if:

  • you want to use the Proffieboard as your SD card reader (as opposed to removing the card and using a standalone USB reader) and
  • if you want to use the ProffieOS Workbench online.

Ohh… So I could essentially go back into Arduino and change it back to Serial ONLY?

I do know that once I’d got done with uploading my config, it kept asking me to “Insert a disk into drive F:” (or whatever the drive letter was) and everytime I clicked on Cancel, that pop-up notification kept returning.

I’m maybe thinking this might’ve been a result of the “+ Mass Storage + WebUSB” extra setting.

Correct. Removing the mass storage option then uploading will stop the SD card from presenting itself to the computer as a disk drive.