Arduino Can't Find Config?

OK, this is an odd one:

I’ve made a config for someone and have emailed them the complete ProffieOS folder, so that all they have to do is open the ProffieOS.ino file and click upload.

On my Mac, everything works fine, but when the recipient tries exactly the same folder on his Windows PC, he gets an error referencing the config saying “No such file or directory”.

The guy has done the Zadig thing, and has updated the plugin to the latest version. I’ve sent him a video of it working on my Mac, and he’s sent me a video of the same process failing on his PC. Board manager and everything else in his Tools menu looks set correctly.

I’ve tried downloading a complete fresh OS from the proffie page and just dropped the config in and edited the .ino to name it, but still no good.

I must say I’m stumped.

Any thoughts welcome.


1 Like

Well, here is a few things to check:

  1. Depending on the way the files were zipped, ProffieOS.ino could end up in a directory not called ProffieOS when you unzip it. If so, Arduino will “helpfully” ask if you want to move ProffieOS.ino into a folder called “ProffieOS”. If you answer “yes” to that question, ProffieOS will not find the config file (or any other include file) and generally just not work.
  2. Arduino is very bad about specifying which file it’s actually using. When you click on an .ino file, Arduino will often open up all the files that were open last time you used Arduino in addition to the one that you clicked on. If all of them are called ProffieOS.ino, it can be very hard to know which one is the new one. I sometimes recommend that people insert an intentional error in their file(s) (ProffieOS.ino in this case) and make sure that when they hit upload or verify, they get an error from that actual file.
  3. If nothing else works, connect over meet/zoom/whatever and have the person you are helping share their desktop while they are unzipping & running Arduino. Hopefully you will be able to spot whatever unexpected / wrong thing they are doing to make it not work.
  4. It could be a file naming thing. Make sure your config file only uses A-Z, 0-9 _ and ends in .h

FInally, some more information that may be helpful:

1 Like

Thanks as always Prof. We got to the bottom of it in the end, and it was along the lines of what you mentioned. For some reason he had various ProffieOS folders (presumably from re-downloading it multiple times) and his Windows PC seemed to jump between them. It was only after studying a second video from him that I noticed the file structure names didn’t seem to follow what he was doing - like the PC would skip back several steps when arrowing back instead of just one - but once we managed to isolate one folder, it worked. So it was more a “his Windows” thing than anything to do with us, so to speak.
Anyway we got there. Thanks again.