Altchng.wav question

trying to setup a dual phase with a Luke font and Vader font.
I want it to play a specific altchng wav when going from Luke to Vader and different altchng wav when going from Vader to Luke.

Is that possible? Thanks

Just put the altchng.wav in the altNNN folders.

1 Like

Does this work as opposed to having 001.wav in an /altchng/ folder?

But this post is inspiring me. I really like the idea of having a blue blade Anakin font that you phase change to a Vader font and the altchng sound is the quote at the end of the prequel trilogy, “Nooooooooooooooooo!!!”

No the altNNN folder is an added component.
Let’s say your font directory is fnord.
Then the altchng.wav would be called: /fnord/alt001/altchng/000.wav
Please remember that the file structure in all alt directories has to be exactly the same. (Same file names, same number of files.) Only the length and content of those files can be different from one alt directory to another.

1 Like

Ressurecting this for a clarification.
Do “altchng” files need to conform to 3 digits starting at zero?

I’ve seen that “tr” files start at “00”. Is that required, and if so, which other files need zero starting numbers and/or place specificity?
I don’t think there’s such documentation yet, so I’m asking.

another related Q: can tr/trloop sound files be in the common folder?

ANY file that works in a font folder can go in common… because it’s a font folder.

I put “altchng.wav” in the common folder, it doesn’t play when switching alt modes in the Survivor blade style. Neither does “tr00.wav” which I also put in common to test.

No,

There are three ways for ProffieOS to find a file.

  1. A specific filename. (Like is used for tracks.)
  2. A single file, but located in any of the font folders. This is how all the sounds in the sound library works. So if your font path is “teensysf;common”, and proffieos wants to play “mexit.wav”, then it will look in “teensysf/mexit.wav” first and then “common/mexit.wav”.
  3. effect sounds, these are numbered files, they can use any number of digits they can be in sub-directores or sub-sub directories and they can use alt directories. The files can be in any of the font path directories, but all the files must be in the same font path directory. (so you can’t have clash01.wav in “teensysf” and “clash02.wav” in “common”. If you try, “clash02.wav” will be ignored, as “teensysf” is first in the font search path.) Effect numbering is very flexible, they can start at 0, 1 or any number, they can also end at any number, as long as all files in between exists. They can use leading zeroes (like clash0005.wav) or not (like clash5.wav) as long as all files in the same effect use the same pattern.

altchng is is an effect, so it follows (3), so is tr.

Whenever something doesn’t work, I suggest using the effects command in the serial monitor to find out why.

1 Like

Thank you Dr.

They can start at any number, that’s wild, but silly to do too I suppose.

Anyway, the point is for my SoundFontNamingConverter, I just want to handle file numbering correctly for all cases. I went through a bunch of hoops and hours setting it to offset “tr” files only by -1. Oh well.
Now I am armed and dangerous.

I needed to support “starts at 0” and “starts at 1”, but it was easier to just take the minimum file number and save it.