Accidentally enabling edit mode?

Hey guys,

I’m having kind of a peculiar issue with several of my sabers with a variety of different configs. I recently updated them all to the new os, which changed all the controls to the twisting through volume and fonts, etc. I love the new controls for the most part, but I’m having an issue where I keep accidentally entering some kind of edit mode. I don’t have edit mode enabled in any of the configs that I can see.

When it happens, I sometimes accidentally add multiples of the same font or change the sound fonts on some of the blade styles. It’s kind of weird and I can’t really find the rhyme or reason with it.

It seems to happen when I am trying to enter the volume menu by pressing power then aux. most often it happens on a like rotj with a rocking button on the button box. This makes me think that maybe I am pressing them simultaneously to enter this mode?

Anybody know what I am doing when this happens? Is it a bug or a feature? Is there any way to undo the changes without reflashing the board?

Thanks everyone.

Post your config file(s).

I didn’t know about adding them since it is happening on several sabers with configs from different manufacturers. I feel like it is something that is supposed to happen, and I just don’t know how to use it. here are a couple of them:


It doesn’t look like edit mode is enabled, and there doesn’t even seem to be state saving configured.

When this happens, does it go away if you cut the power to the board and then start it up again?

Do you have a presets.ini / presets.tmp file on your SD card?
(If so, can you attach those as well?) After attaching, try deleting them and see if that makes the “edits” disappear?

What is the exact version of ProffieOS you have?

It sounds like you’re doing the control for Copy Preset.

I recommend reading and familiarizing yourself with the controls.

You can disable this feature with this define


There’s also many other defines to disable (or enable features). My config tool can make it much easier to customize the prop. Just watch the videos at the top and read through the instructions. This tool will also provide a custom control list based on the options you choose.

that’s what I thought. ryryog took a look at it, too, and said the same.

no, the edits stay even if I remove the battery

Yes! It just happened again with a saber. I was trying to enter volume mode, and somehow one of my fonts way down the list ended up in the 2nd preset. you can see it in the .tmp file. it is the Windu’s Revenge one. that was the 11th font or so originally, but it switched it to the second preset. when I deleted the .tmp file from the card and reinserted it, it was back to normal. it did make the “edits” disappear. that’s a lot easier than reuploading the config, but I still wish I could figure out how to stop doing it. or undo it from the hilt. here is the .tmp file:

I’m embarrassed to say that I don’t know. where do I check that? I think it’s pretty recent. I see this in the .ini: const char version[] = "v7.13";. is that the os I’m using?

thanks again.

See my post, you’re doing the wrong controls, this means you did “Change Font” control. This can also be disabled with a define :wink:

Oops! I hadn’t seen your post when I wrote all that! :melting_face:


yep, these two are what I keep accidentally doing:

  • Change Font
    • Next Font = Hold AUX, Long Click PWR (parallel or up)
    • Previous Font = Hold Aux, Long Click PWR (pointing down)
  • Copy Preset = Hold PWR, Long Click AUX

disabling copy preset should fix the first part. can I also do this?

I also might be doing this:

  • Change Style (All Blades)
    • Next Style = Hold AUX, Long Click PWR (parallel or up)
    • Previous Style = Hold Aux, Long Click PWR (pointing down)

can I also do this?


Ah, I see.

Not sure if you’re using ProffieConfig still, but fwiw those options are in the Disables section on fett’s Prop Files page of the editor:

EDIT: Don’t forget, you can hover over the options to get a more detailed explanation.

All of the defines are listed on the prop page linked above or use my config tool, it’s specifically designed to help customize my prop.

awesome. I see them now. thanks.

I wasn’t able to get the config helper working last time I tried it. I need to try it again.

awesome. got everything figured out. I added those three disable commands, and it’s working great. thanks everyone for your help. now I need to duplicate it on all my other ones, lol.

You’re welcome, glad you got it sorted.